cancel
Showing results for 
Search instead for 
Did you mean: 
Create a Post
Highlighted
israelgl
Iron

adding network object with mgmt_cli batch CSV file

Jump to solution

i try to add number of network object with cli tool but i received an error.

i followed sk113078 and did exactly the same and received the error:

Line 2: code: "generic_err_invalid_parameter_name"
message: "Unrecognized parameter [name]"

Line 3: code: "generic_err_invalid_parameter_name"
message: "Unrecognized parameter [name]"

Line 4: code: "generic_err_invalid_parameter_name"
message: "Unrecognized parameter [name]"


Executed command failed. Changes are discarded.

 

the csv is:

name,subnet,subnet-mask
network1,10.10.10.0,255.255.255.0
network2,20.20.20.0,255.255.255.0
network3,30.30.30.0,255.255.255.0

 

 

i have R80.20 take: 103

0 Kudos
1 Solution

Accepted Solutions
Admin
Admin

Re: adding network object with mgmt_cli batch CSV file

Jump to solution
This seems like a bug to me.
In R80.30, the above works using both the 1.5 (R80.30) and 1.3 (R80.20) versions of the API.
Suggest opening a TAC case.

View solution in original post

0 Kudos
5 Replies

Re: adding network object with mgmt_cli batch CSV file

Jump to solution
what's the command syntax which you use to do batch work?
0 Kudos
israelgl
Iron

Re: adding network object with mgmt_cli batch CSV file

Jump to solution

mgmt_cli add network --batch network.csv

0 Kudos
Maik
Silver

Re: adding network object with mgmt_cli batch CSV file

Jump to solution
Sounds like a bug to be honest. Without being able to test it on my own it seems like you specified everything in the correct way. Could you try to run the same command with "--version 1.1" in the end to force the API down to version 1.1? I used this command before and I'm quite sure that it worked. Also; do you experience this issue only via the batch mode or also via "manually" creating one network with the specified parameters?
0 Kudos
israelgl
Iron

Re: adding network object with mgmt_cli batch CSV file

Jump to solution

i tried with "--version 1.1", same error.

manually adding with "mgmt_cli", works fine.

0 Kudos
Admin
Admin

Re: adding network object with mgmt_cli batch CSV file

Jump to solution
This seems like a bug to me.
In R80.30, the above works using both the 1.5 (R80.30) and 1.3 (R80.20) versions of the API.
Suggest opening a TAC case.

View solution in original post

0 Kudos