Create a Post
cancel
Showing results for 
Search instead for 
Did you mean: 
marius_kade
Participant
Jump to solution

Setting an DHCP Reservation in CheckPoint DHCP Server on 6400

Hello everyone,

Our CheckPoint Cluster manages DHCP in some of our networks. I'm trying to ensure that a specific device always gets the same IP address, and I'd like to achieve this through DHCP reservation or another option.

Despite searching online and in the forum, I haven't been able to find a solution. Does anyone now how to do this on a CheckPoint 6400 Base Cluster?

Thanks for your assistance,
Marius

0 Kudos
1 Solution

Accepted Solutions
PhoneBoy
Admin
Admin

Yes, it needs to be entered on both cluster members and it may require a restart of dhcpd.
I believe the main thing to be entered is the host testclient stanza (each line needs a semicolon at the end). 

View solution in original post

5 Replies
PhoneBoy
Admin
Admin

Requires editing a configuration file.
See: https://support.checkpoint.com/results/sk/sk92473

marius_kade
Participant

Thanks for your reply.

So as i understand right, i have to write it like the example below in the dhcpd.conf file right?
Do have to this on both cluster members?

Can i use the IP-address of the lease that the client already has or do i have to pick a not assigned one?

Example:
________________________________________________________________
ddns-update-style none;
 
 
subnet 192.168.89.0 netmask 255.255.255.0 {
    default-lease-time 43200;
    max-lease-time 86400;
    option host-name= pick(option host-name,
       concat("dhcp-", binary-to-ascii(10, 8, "-", leased-address)));
    range 192.168.89.10 192.168.89.254;
    option routers 192.168.89.1;
    option domain-name-servers 9.9.9.9, 1.1.1.1;
}
 
host testclient {
hardware ethernet 08:50:40:A2:F2:3D
fixed-address 192.168.89.20
}
 
________________________________________________________________
 
Thanks for your help!!!
 
Marius
0 Kudos
marius_kade
Participant

Thank you for your response!

Sorry for my late response, but I had already written something, but it either disappeared or never appeared.

 

So, does that mean I have to enter it in the dhcpd.conf file, right?
Should I do that on both cluster members? Or maybe even on the management server?
Is this syntax correct?

Config example:

ddns-update-style none;
 
 
subnet 192.168.89.0 netmask 255.255.255.0 {
    default-lease-time 43200;
    max-lease-time 86400;
    option host-name= pick(option host-name,
       concat("dhcp-", binary-to-ascii(10, 8, "-", leased-address)));
    range 192.168.89.10 192.168.89.254;
    option routers 192.168.89.1;
    option domain-name-servers 9.9.9.9, 1.1.1.1;
}
 
host testclient {
hardware ethernet 08:50:40:A2:F2:3D
fixed-address 192.168.89.20
}
0 Kudos
PhoneBoy
Admin
Admin

Yes, it needs to be entered on both cluster members and it may require a restart of dhcpd.
I believe the main thing to be entered is the host testclient stanza (each line needs a semicolon at the end). 

marius_kade
Participant

Many Thanks! I will try it.

0 Kudos

Leaderboard

Epsum factorial non deposit quid pro quo hic escorol.

Upcoming Events

    Tue 23 Apr 2024 @ 11:00 AM (EDT)

    East US: What's New in R82

    Thu 25 Apr 2024 @ 11:00 AM (SGT)

    APAC: CPX 2024 Recap

    Tue 30 Apr 2024 @ 03:00 PM (CDT)

    EMEA: CPX 2024 Recap

    Thu 02 May 2024 @ 11:00 AM (SGT)

    APAC: What's new in R82

    Tue 23 Apr 2024 @ 11:00 AM (EDT)

    East US: What's New in R82

    Thu 25 Apr 2024 @ 11:00 AM (SGT)

    APAC: CPX 2024 Recap

    Tue 30 Apr 2024 @ 03:00 PM (CDT)

    EMEA: CPX 2024 Recap

    Thu 02 May 2024 @ 11:00 AM (SGT)

    APAC: What's new in R82
    CheckMates Events