Create a Post
cancel
Showing results for 
Search instead for 
Did you mean: 
checkpointer
Participant

R81 VSX site to site vpn source interface

Hello 

In the following topology, I would like to change the source interface for my site-to-site VPN from my gateway's main public IP address to another interface on the gateway, but I have nothing in the drop-down when I try to do this in the gateway object inside the community. I cannot change the main gateway IP address as this affects other VPNs.

Currently:

(GW main interface) 10.10.10.10 ------------->192.168.10.10 (3rd Party)

But I want:

(GW other interface) 20.20.20.20 ------------->192.168.10.10 (3rd Party)

I try to change my source interface inside VPN community but get nothing in drop-down:

vpn2.JPG

 

 

0 Kudos
8 Replies
JanVC
Collaborator

are you trying to change this on the interoperable device/remote end instead of your own virtual system?

0 Kudos
checkpointer
Participant

I'm trying to change my own source interface on my device, not remote peer

0 Kudos
JanVC
Collaborator

that i understand, but judging by the screenshot it looks like you are editing the interoperable device since you are missing alot of stuff

first screenshot is of an interoperable device, second is of a virtual system

 

0 Kudos
checkpointer
Participant

I suppose the question then is whether the object has been created correctly? It's a VSX environment and I'll check this again with my customer. 

0 Kudos
skandshus
Collaborator

Skærmbillede 2022-04-13 221851.png

0 Kudos
skandshus
Collaborator

This is Agree.

You need to open the "properties" on the virtual system.. the amount of options available from the screenshot is WAAAAAY too limited.. the "interoperable" device shouldnt be able to change the interface,.. it will never know what interface the virtual system has In real life 😉

0 Kudos
checkpointer
Participant

Thanks guys, yes I inadvertently posted the wrong graphic and the one above is correct- the question however is that I have indeed changed the link selection as show above to a my desired interface but the traffic when passing through does not pick up that interface as it's source address, it picks up a source address from another interface (which is not also not the main interface by the way).

 

0 Kudos
Wolfgang
Mentor
Mentor

You have to use the button „Source IP address settings…“ to configure your outgoing IP address.

0 Kudos