Create a Post
cancel
Showing results for 
Search instead for 
Did you mean: 
PavelSpiridonov
Participant
Jump to solution

R77.20.87 - Configuring BGP reflector-client

Hi!
When setting BGP via Gaia Clish (because in R77.x BGP setting is not available from Gaia Portal), when
specifying command 'set bgp internal peer 10.0.1.10 peer-type reflector-client on'
it gives an error 'Peer 10.0.1.10 can't be configured in multiple groups'.
How to set up this 'groups'?

0 Kudos
1 Solution

Accepted Solutions
Chris_Atkinson
Employee
Employee

Which build of R77.20.87 is used?

This command should help you see any configured peer-groups ...

[Expert@S21]# cat /etc/routed0.conf

View solution in original post

0 Kudos
7 Replies
PhoneBoy
Admin
Admin

Where else in your BGP configuration have you mentioned 10.0.1.10?

0 Kudos
PavelSpiridonov
Participant

I would also like to know how you can see it ... The a command 'show configuration' produces a lot of lines of text, but this IP-address is not found there even in those places that I know (for example - set bgp internal peer 10.0.1.10... etc)

0 Kudos
Chris_Atkinson
Employee
Employee

Which build of R77.20.87 is used?

This command should help you see any configured peer-groups ...

[Expert@S21]# cat /etc/routed0.conf

0 Kudos
PavelSpiridonov
Participant

Build - R77.20.87 990173127

Unfortunately, I get a refusal on the 'cat' command. Probably, this requires privilege escalation or the inclusion of some kind of expert mode.

0 Kudos
PhoneBoy
Admin
Admin

cat is an expert mode command.
Enter "expert" and the relevant password, then you can execute the command: cat /etc/routed0.conf

Unfortunately, the dynamic routing configuration does not show in the show configuration output.
It's possible this is addressed in future releases, which are available on newer hardware.

PavelSpiridonov
Participant

Thanks, the command 'cat /etc/routed0.conf' showed what the problem was. It turns out that it is impossible to modify the peer to the reflector mode. It must be removed and then added in reflector mode. But there was one more, quite expected in such cases, problem. Namely, the 'next hop self' option. The command 'set bgp internal nexthop-self on' did not lead to the expected result - the route is still advertised from the original IP-address.

0 Kudos
PhoneBoy
Admin
Admin

I recommend working with the TAC on this.

0 Kudos