Create a Post
cancel
Showing results for 
Search instead for 
Did you mean: 
mbouri
Explorer

Check Point Ansible Module 2.9 with MDS

Hello, we are testing ansible automatisation on our MDS, but it dosn't work for me

My Hosts File looks like this: the 1.1.1.1 is the CMA IP

[checkpoint]
1.1.1.1  

my_var file is :

ansible_httpapi_use_ssl: True
ansible_httpapi_validate_certs: False
ansible_user: api-user
ansible_network_os: checkpoint
ansible_password: password

My Ansible runbook lookes like that:

cat check_grp.yml

---
- name: test
hosts: all
connection: httpapi
gather_facts: yes

vars_files:
- 'my_var .yaml'


tasks:

- name: show-group
cp_mgmt_group_facts:
details_level: standard
name: "grp_Demo"
register: grp_facts
vars:
ansible_checkpoint_domain: "CMA_NAME"

I have always {"changed": false, "msg": "Checkpoint device returned error 404 with message {u'message': u'Requested object [grp_Demo] not found

is there any other options to add in the playbook ?

 

0 Kudos
2 Replies
PhoneBoy
Admin
Admin

To use the Ansible module you may need to install a Jumbo Hotfix on your MDS.
Refer to: https://supportcenter.checkpoint.com/supportcenter/portal?eventSubmit_doGoviewsolutiondetails=&solut...
0 Kudos
mbouri
Explorer

Hello,

the hotfix installed is R80.30 Take 155, the ansible module work fine for SMS but  dosn't work on our MDS

the hotfix installed is R80.30 Take 155

This is Check Point CPinfo Build 914000196 for GAIA
Local host is not a Gateway
[IDA]
       No hotfixes..

[CPFC]
       HOTFIX_R80_30_JUMBO_HF_MAIN     Take:  155

[MGMT]
       HOTFIX_R80_30_JUMBO_HF_MAIN     Take:  155

[FW1]
       HOTFIX_R80_30_JUMBO_HF_MAIN     Take:  155

FW1 build number:
This is Check Point Security Management Server R80.30 - Build 016
This is Check Point's software version R80.30 - Build 001

[SecurePlatform]
       HOTFIX_GOGO_LT_HEAT_JHF Take:  155

[NGXCMP]
       No hotfixes..

[EdgeCmp]
       No hotfixes..

[SFWCMP]
       No hotfixes..

[SFWR75CMP]
       No hotfixes..

[SFWR77CMP]
       No hotfixes..

[FLICMP]
       No hotfixes..

[R75CMP]
       No hotfixes..

[R7520CMP]
       No hotfixes..

[R7540CMP]
       No hotfixes..

[R76CMP]
       HOTFIX_R80_30_JHF_COMP  Take:  155

[R77CMP]
       HOTFIX_R80_30_JHF_COMP  Take:  155

[PROVIDER-1]
       HOTFIX_R80_30_JUMBO_HF_MAIN     Take:  155

[Reporting Module]
       HOTFIX_R80_30_JUMBO_HF_MAIN     Take:  155

[SmartLog]
       HOTFIX_R80_30_JUMBO_HF_MAIN     Take:  155

[CPinfo]
       No hotfixes..

[VSEC]
       HOTFIX_R80_30_JUMBO_HF_MAIN     Take:  155

[DIAG]
       No hotfixes..

[MGMTAPI]
       No hotfixes..

[CPUpdates]
       BUNDLE_INFRA_AUTOUPDATE Take:  24
       BUNDLE_DEP_INSTALLER_AUTOUPDATE Take:  13
       BUNDLE_R80_30_JUMBO_HF_MAIN_gogoKernel  Take:  155

[SFWR80CMP]
       No hotfixes..

[AutoUpdater]
       No hotfixes..

[CPDepInst]
       No hotfixes..

 

Regards

 

Mounir

0 Kudos