Create a Post
cancel
Showing results for 
Search instead for 
Did you mean: 
rishrapsody1612
Participant

Unable to install gaia_api on CheckPoint VM appliance

I am unable to install gaia_api module on Checkpoint VM appliance.

Steps followed:
1. Downloaded Check_Point_gaia_api.tar from https://supportcenter.checkpoint.com/supportcenter/portal?eventSubmit_doGoviewsolutiondetails=&solut...

2. 'tar -xvf Check_Point_gaia_api.tar' in local directory
3. ./install_gaia_api.sh  in the same directory

Output:
[Expert@planofw]# ./install_gaia_api.sh
Starting gaia_api installation
Old version removed successfully
Installing gaia_api...
Failed to install 'os_yaml-1.5-cp991255001.i386.rpm'

 

[Expert@planofw]# rpm -qpi os_yaml-1.5-cp991255001.i386.rpm
Name : os_yaml
Version : 1.5
Release : cp991255001
Group : System Environment/Base
Size : 465661
License : Check Point
Source RPM : os_yaml-1.5-cp991255001.src.rpm
Build Date : Mon 12 Oct 2020 12:27:00 UTC
Build Host : Lnx50BccCmp6.checkpoint.com
Relocations : (not relocatable)
Vendor : Check Point
Summary : Pyyaml open source Package
Description :
Pyyaml open source libraries

[Expert@planofw]# cat /etc/cp-release
Check Point GAiA Embedded R80.20

[Expert@planofw]# cat /etc/cd.ver
CD_BUILD=992001682
CD_MV='R80'
CD_FP='R80'
CD_SP=''
SU_Major='R80'
SU_Minor='R80'
CP_BUILD_NUM=992001682
CP_MAJOR_VER=R80
CP_MINOR_VER=20
CP_HFA_VER=15

=================

Please help....

 

0 Kudos
1 Reply
_Val_
Admin
Admin

Gaia API is for full Gaia, and not Gaia embedded. You cannot use it on SMB appliances. Use regular Gaia VM image, instead of SMB

0 Kudos