Create a Post
cancel
Showing results for 
Search instead for 
Did you mean: 
tali1974
Explorer

Check Point Terraform Provider v1.9.1

terraform plan give me this error.

 

│ Error: failed to execute API call
│ Status: 400 Bad Request
│ Code: generic_err_invalid_parameter
│ Message: Could not parse [<MyPublicIP>, <Zscaler IP>]

│ with provider["registry.terraform.io/checkpointsw/checkpoint"],
│ on main.tf line 10, in provider "checkpoint":
│ 10: provider "checkpoint" {

 

on the management server

[Expert@cpcgmgmt01:0]# api status

API Settings:
---------------------
Accessibility: Require local
Require ip <Zscaler IP>/255.255.255.0 <MyPublicIP>
Automatic Start: Enabled

If I allow ALL IP addresses ("Require all granted" as shown below.)  in the API settings it works just fine. Any idea what the issue can be ?

API Settings:
---------------------
Accessibility: Require all granted
Automatic Start: Enabled

0 Kudos
3 Replies
PhoneBoy
Admin
Admin

That, to me, suggests access isn't happening from the IP you think it is.
Check with tcpdump when you trying to execute terraform to verify what the precise IP that is trying to access.
If you have the correct IP and it still fails, open a TAC case.

0 Kudos
tali1974
Explorer

Thanks for your reply. the access is happing from that IP, When i open for ALL ips, i can see in the SmartConsole >> ViewSessions 

Connected from is <Zscaler IP>,<MyPublicIP>

0 Kudos
PhoneBoy
Admin
Admin

This sounds like a bug and you'll need a TAC case to get the issue resolved.

0 Kudos