Create a Post
cancel
Showing results for 
Search instead for 
Did you mean: 
Kaspars_Zibarts
Authority
Authority

VSX kernel upgrade to 3.10 R80.30 T215

Jump to solution

Hi! Just wondering if anyone has done kernel upgrade from 2.6 to 3.10?

We were trying to upgrade our 23800 VSX cluster but faced really bizarre sync issues. Just wondering if there are any special tricks to consider, especially that our 2.6 kernel is running CCP broadcast and 3.10 will be unicast.

Was really long night with other upgrades and SSDs dying on us so had no time to dig into it

0 Kudos
Reply
1 Solution

Accepted Solutions
shlomip
Employee
Employee

@Kaspars_Zibarts ,

Yes. You can upgrade R80.30 kernel 2.6.18 to R80.40 (it's 3.1 kernel by default)

View solution in original post

0 Kudos
Reply
4 Replies
Kaspars_Zibarts
Authority
Authority

I'm almost starting to believe that this "upgrade" R80.30 T215 2.6 > R80.30 T215 3.10 is not going to work.

Our only option to upgrade kernel to 3.10 would be by going to R80.40 where it explicitly says in release notes "Security Gateway upgrade from 2.6.18 kernel to 3.10 kernel is supported.@Ilya_Yusupov  do you happen to know anyone who could confirm this?

0 Kudos
Reply
shlomip
Employee
Employee

@Kaspars_Zibarts ,

Yes. You can upgrade R80.30 kernel 2.6.18 to R80.40 (it's 3.1 kernel by default)

View solution in original post

0 Kudos
Reply
Kaspars_Zibarts
Authority
Authority

Now that I had time to read R80.40 upgrade manual it all makes sense.. MVC (multi version cluster) only supported with R80.40.. That makes the "glue" then between different kernel versions and CCP.. So R80.30 2.6 and R80.30 3.10 will never synchronise. ouch, hard lesson.

Would be nice though if this was stated in R80.30 3.10 release notes as I just assumed that both 2.6 and 3.10 versions support unicast therefore clustering and sync would work.

Basically we only needed 3.10 to improve NIC performance (RX-DRP) when using MQ and avoid 5 interface limit with it.

0 Kudos
Reply
Ilya_Yusupov
Employee
Employee

Hi @Kaspars_Zibarts ,

As Shlomi mention you need to upgrade to R80.40.

You can't do upgrade from/to same version even if OS kernel is different.

 

Let me know if anything else is needed.

 

Thanks,

Ilya

0 Kudos
Reply