Create a Post
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted

Threat Emulation Terminating VM due to error: failed to start tap interface

Jump to solution

Hi,

After update image on  sandblast appliance T250 gaia R80.20, VM not start. 

Error: Terminating VM due to error: failed to start tap interface

Emulator log:

[18146 4076272128][21 May  1:40:24] [TE_TRACE]: {E5FDCED7-A838-5743-B9A0-59E0701233E1} Adding emulation request on Image: '10b4a9c6-e414-425c-ae8b-fe4dd7b25244', Run: 1, Priority: normal (0 requests in queue, 0 running emulation VMs)

[18146 4076272128][21 May  1:40:24] [TE_TRACE]: {E5FDCED7-A838-5743-B9A0-59E0701233E1} Adding emulation request on Image: '3ff3ddae-e7fd-4969-818c-d5f1a2be336d', Run: 1, Priority: normal (1 requests in queue, 0 running emulation VMs)

[18146 4076272128][21 May  1:40:24] [TE_TRACE]: {E5FDCED7-A838-5743-B9A0-59E0701233E1} Adding emulation request on Image: '5e5de275-a103-4f67-b55b-47532918fa59', Run: 1, Priority: normal (2 requests in queue, 0 running emulation VMs)

[18146 4076272128][21 May  1:40:24] [TE_TRACE]: {E5FDCED7-A838-5743-B9A0-59E0701233E1} Adding emulation request on Image: '5e5de275-a103-4f67-b55b-47532918fa59HPS', Run: 1, Priority: normal (3 requests in queue, 0 running emulation VMs)

[18146 4076272128][21 May  1:40:24] [TE_TRACE]: VM 12 KeyPoint: creation. is_hps=0

[18146 4076272128][21 May  1:40:24]  [TE (TD::Surprise)] te::Emulation::VMloader::CreateTapInterface: failed to set IP address '169.254.0.1' to interface 'vm-if0, netmask: 255.255.255.252)

[18146 4076272128][21 May  1:40:24]  [TE (TD::Surprise)] te::VmResources::ConsumedRes::StartTap: failed to create tap vm-if0 169.254.0.1/255.255.255.252

[18146 4076272128][21 May  1:40:24] [TE_TRACE]: VM 12 KeyPoint: Terminating VM due to error: failed to start tap interface

[18146 4076272128][21 May  1:40:24]  [TE (TD::Surprise)] te::Emulation::EmulatingVM::TerminateWithError: VM 12 (Creation In Process): Terminating VM due to error: failed to start tap interface

[18146 4076272128][21 May  1:40:24] [TE_TRACE]: VM 12 KeyPoint: Terminating (error occured? 1, detected events: 0 malicious, 0 benign)

[18146 4076272128][21 May  1:40:24] [TE_TRACE]: VM 12 KeyPoint: destroying. max number of files: 0. life time: 0

[18146 4076272128][21 May  1:40:24]  [TE (TD::Surprise)] te::Emulation::VMrepository::CreateNewVM: VM 12 failed to start

[18146 4076272128][21 May  1:40:24] [TE_TRACE]: {E5FDCED7-A838-5743-B9A0-59E0701233E1} verdict 'Error' set for image: '3ff3ddae-e7fd-4969-818c-d5f1a2be336d' (Win7 64b,Office 2010,Adobe 11) by: 1, reason: Failed to create VM for Win7 64b,Office 2010,Adobe 11

[18146 4076272128][21 May  1:40:24] [TE_TRACE]: {E5FDCED7-A838-5743-B9A0-59E0701233E1} investigator 'emulator' reporting back (status: still working)

[18146 4076272128][21 May  1:40:24] [TE_TRACE]: VM 13 KeyPoint: creation. is_hps=0

[18146 4076272128][21 May  1:40:24]  [TE (TD::Surprise)] te::Emulation::VMloader::CreateTapInterface: failed to set IP address '169.254.0.1' to interface 'vm-if0, netmask: 255.255.255.252)

[18146 4076272128][21 May  1:40:24]  [TE (TD::Surprise)] te::VmResources::ConsumedRes::StartTap: failed to create tap vm-if0 169.254.0.1/255.255.255.252

[18146 4076272128][21 May  1:40:24] [TE_TRACE]: VM 13 KeyPoint: Terminating VM due to error: failed to start tap interface

[18146 4076272128][21 May  1:40:24]  [TE (TD::Surprise)] te::Emulation::EmulatingVM::TerminateWithError: VM 13 (Creation In Process): Terminating VM due to error: failed to start tap interface

[18146 4076272128][21 May  1:40:24] [TE_TRACE]: VM 13 KeyPoint: Terminating (error occured? 1, detected events: 0 malicious, 0 benign)

[18146 4076272128][21 May  1:40:24] [TE_TRACE]: VM 13 KeyPoint: destroying. max number of files: 0. life time: 0

[18146 4076272128][21 May  1:40:24]  [TE (TD::Surprise)] te::Emulation::VMrepository::CreateNewVM: VM 13 failed to start

[18146 4076272128][21 May  1:40:24] [TE_TRACE]: {E5FDCED7-A838-5743-B9A0-59E0701233E1} verdict 'Error' set for image: '5e5de275-a103-4f67-b55b-47532918fa59' (Win7,Office 2013,Adobe 11) by: 1, reason: Failed to create VM for Win7,Office 2013,Adobe 11

[18146 4076272128][21 May  1:40:24] [TE_TRACE]: {E5FDCED7-A838-5743-B9A0-59E0701233E1} verdict 'Error' set for image: '5e5de275-a103-4f67-b55b-47532918fa59HPS' () by: 40, reason:

[18146 4076272128][21 May  1:40:24] [TE_TRACE]: {E5FDCED7-A838-5743-B9A0-59E0701233E1} investigator 'emulator' reporting back (status: still working)

[18146 4076272128][21 May  1:40:24] [TE_TRACE]: VM 14 KeyPoint: creation. is_hps=1

[18146 4076272128][21 May  1:40:24]  [TE (TD::Surprise)] te::Emulation::VMloader::CreateTapInterface: failed to set IP address '169.254.0.1' to interface 'vm-if0, netmask: 255.255.255.252)

[18146 4076272128][21 May  1:40:24]  [TE (TD::Surprise)] te::VmResources::ConsumedRes::StartTap: failed to create tap vm-if0 169.254.0.1/255.255.255.252

[18146 4076272128][21 May  1:40:24] [TE_TRACE]: VM 14 KeyPoint: Terminating VM due to error: failed to start tap interface

[18146 4076272128][21 May  1:40:24]  [TE (TD::Surprise)] te::Emulation::EmulatingVM::TerminateWithError: VM 14 (Creation In Process): Terminating VM due to error: failed to start tap interface

[18146 4076272128][21 May  1:40:24] [TE_TRACE]: VM 14 KeyPoint: Terminating (error occured? 1, detected events: 0 malicious, 0 benign)

[18146 4076272128][21 May  1:40:24] [TE_TRACE]: VM 14 KeyPoint: destroying. max number of files: 0. life time: 0

[18146 4076272128][21 May  1:40:24]  [TE (TD::Surprise)] te::Emulation::VMrepository::CreateNewVM: VM 14 failed to start

[18146 4076272128][21 May  1:40:24] [TE_TRACE]: {E5FDCED7-A838-5743-B9A0-59E0701233E1} verdict 'Error' set for image: '5e5de275-a103-4f67-b55b-47532918fa59HPS' () by: 1, reason: Failed to create VM for

[18146 4076272128][21 May  1:40:24] [TE_TRACE]: {E5FDCED7-A838-5743-B9A0-59E0701233E1} verdict 'Error' set for image: '5e5de275-a103-4f67-b55b-47532918fa59' (Win7,Office 2013,Adobe 11) by: 40, reason:

[18146 4076272128][21 May  1:40:24] [TE_TRACE]: {E5FDCED7-A838-5743-B9A0-59E0701233E1} investigator 'emulator' reporting back (status: still working)

[18146 4076272128][21 May  1:40:24] [TE_TRACE]: VM 15 KeyPoint: creation. is_hps=0

[18146 4076272128][21 May  1:40:24]  [TE (TD::Surprise)] te::Emulation::VMloader::CreateTapInterface: failed to set IP address '169.254.0.1' to interface 'vm-if0, netmask: 255.255.255.252)

[18146 4076272128][21 May  1:40:24]  [TE (TD::Surprise)] te::VmResources::ConsumedRes::StartTap: failed to create tap vm-if0 169.254.0.1/255.255.255.252

[18146 4076272128][21 May  1:40:24] [TE_TRACE]: VM 15 KeyPoint: Terminating VM due to error: failed to start tap interface

[18146 4076272128][21 May  1:40:24]  [TE (TD::Surprise)] te::Emulation::EmulatingVM::TerminateWithError: VM 15 (Creation In Process): Terminating VM due to error: failed to start tap interface

[18146 4076272128][21 May  1:40:24] [TE_TRACE]: VM 15 KeyPoint: Terminating (error occured? 1, detected events: 0 malicious, 0 benign)

[18146 4076272128][21 May  1:40:24] [TE_TRACE]: VM 15 KeyPoint: destroying. max number of files: 0. life time: 0

[18146 4076272128][21 May  1:40:24]  [TE (TD::Surprise)] te::Emulation::VMrepository::CreateNewVM: VM 15 failed to start

[18146 4076272128][21 May  1:40:24] [TE_TRACE]: {E5FDCED7-A838-5743-B9A0-59E0701233E1} verdict 'Error' set for image: '10b4a9c6-e414-425c-ae8b-fe4dd7b25244' (Win10 64b,Office 2016,Adobe DC) by: 1, reason: Failed to create VM for Win10 64b,Office 2016,Adobe DC

 

Thanks.

 

 

0 Kudos
1 Solution

Accepted Solutions
Highlighted

I solve problem.

 

First i clean cache and delete all Image

#tecli cache clear

#rm -rf /var/log/files_repository/images

Then I copy offline update  "Slim Package" on  sandbox in path /var/log/files_repository/offline_update/ (download  from sk92509 https://supportcenter.checkpoint.com/supportcenter/portal?eventSubmit_doGoviewsolutiondetails=&solut...)

Unpack

#tar -xvf <Name_of_Package>.tar

Next u Created needed files for the offline update

# touch /var/log/files_repository/offline_update/enable_update_{0..4}

Kill demon treat emulation

#fw kill ted

start update 

# tecli advanced downloads update all

 

Now, all VM is work.

 

 

 

View solution in original post

0 Kudos
7 Replies
Highlighted
Admin
Admin
Highly recommend opening a TAC case on this.
0 Kudos
Highlighted
Employee
Employee

Hi

In addition to the option of opening support ticket, could you run the following commands the paste the output:

1. qemuUtil add vm-if111 netmask 255.255.255.252 ip 169.254.0.241 up

2. ifconfig | grep -A 3 "vm-if"

3. ifconfig | wc -l

0 Kudos
Thanks for your reply .
I solved the problem in a different way.
0 Kudos
Highlighted

I solve problem.

 

First i clean cache and delete all Image

#tecli cache clear

#rm -rf /var/log/files_repository/images

Then I copy offline update  "Slim Package" on  sandbox in path /var/log/files_repository/offline_update/ (download  from sk92509 https://supportcenter.checkpoint.com/supportcenter/portal?eventSubmit_doGoviewsolutiondetails=&solut...)

Unpack

#tar -xvf <Name_of_Package>.tar

Next u Created needed files for the offline update

# touch /var/log/files_repository/offline_update/enable_update_{0..4}

Kill demon treat emulation

#fw kill ted

start update 

# tecli advanced downloads update all

 

Now, all VM is work.

 

 

 

View solution in original post

0 Kudos
Highlighted
Employee
Employee

Thanks for updating the issue is already solved.

May I ask if I understood correctly that the problem started when you updated the T250 appliance to R80.20?

If so, what was your previous version installed on this appliance? how did you performed the update - with CPUSE (from GAIA web UI)?

0 Kudos
Highlighted
The problem started when T250X connect to internen (after 30 day offline) and update engine and image on last versions.
0 Kudos
Highlighted
Employee
Employee

Thanks for updating that the problem already solved.

May I ask if I understood correctly and the problem started after updating T250 appliance to R80.20?

If so -

What was the previous version installed on the appliance?

How did you performed the update? with CPUSE?

0 Kudos