Create a Post
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted

MTA NDR with "-oi" as sender

Jump to solution

Hi all,
At a customer we have setup the following configuration according to this:

ATRG: Mail Transfer Agent (MTA)
https://supportcenter.checkpoint.com/supportcenter/portal?eventSubmit_doGoviewsolutiondetails=&solut...

Since we check the logs for error messages we sometimes see the following when the MTA is sending "None delivery messages" (NDR):

Jul 22 13:47:04 2019 fwvsx01 postfix/pickup[30252]: 45sfwS1bk8z5x1D: uid=0 from=
Jul 22 13:47:04 2019 fwvsx01 postfix/cleanup[13678]: 45sfwS1bk8z5x1D: message-id=<45sfwS1bk8z5x1D@fwvsx01.domain.com>
Jul 22 13:47:04 2019 fwvsx01 postfix/qmgr[8456]: 45sfwS1bk8z5x1D: from=, size=283, nrcpt=2 (queue active)
Jul 22 13:47:04 2019 fwvsx01 postfix/error[4397]: 45sfwS1bk8z5x1D: to=<-oi@fwvsx01.domain.com>, orig_to=<-oi>, relay=none, delay=0.01, delays=0.01/0/0/0, dsn=5.1.3, status=bounced (bad address syntax)
Jul 22 13:47:04 2019 fwvsx01 postfix/smtp[13664]: 45sfwS1bk8z5x1D: to=, relay=1.3.2.3[1.3.2.3]:25, delay=0.02, delays=0.01/0/0/0.01, dsn=2.0.0, status=sent (250 2.0.0 Ok: queued as 389501CC2D)
Jul 22 13:47:04 2019 fwvsx01 postfix/bounce[4398]: 45sfwS1bk8z5x1D: sender non-delivery notification: 45sfwS1kG7z5x1F
Jul 22 13:47:04 2019 fwvsx01 postfix/qmgr[8456]: 45sfwS1bk8z5x1D: removed

The relevant part of the log above is the following:

Jul 22 13:47:04 2019 fwvsx01 postfix/error[4397]: 45sfwS1bk8z5x1D: to=<-oi@fwvsx01.domain.com>, orig_to=<-oi>, relay=none, delay=0.01, delays=0.01/0/0/0, dsn=5.1.3, status=bounced (bad address syntax)

I figured out that the parameter "-oi" is used in the postfix sendmail binary:

http://www.postfix.org/sendmail.1.html

       -oi    When reading a message from standard input, don't treat  a  line
              with only a . character as the end of input.

So it seems for me that some script is running wrong.

 

Does someone of you have also seen this?
Is there any fix for this problem?

Thanks,
Peter

0 Kudos
1 Solution

Accepted Solutions
Highlighted

Hi all,

The solution was to install the HFA R80_10_mta Take 25.

We have now running the following MTA and the "-oi" messages are gone now:

# cat $FWDIR/conf/mta_ver
8010.991003033

sk123174 - Mail Transfer Agent Update - What's New

 

View solution in original post

0 Kudos
2 Replies
Highlighted
Admin
Admin
I recommend getting the TAC involved.
0 Kudos
Highlighted

Hi all,

The solution was to install the HFA R80_10_mta Take 25.

We have now running the following MTA and the "-oi" messages are gone now:

# cat $FWDIR/conf/mta_ver
8010.991003033

sk123174 - Mail Transfer Agent Update - What's New

 

View solution in original post

0 Kudos