cancel
Showing results for 
Search instead for 
Did you mean: 
Create a Post
Highlighted
Employee+
Employee+

Endpoint Security / SandBlast Agent Newsletter - Version – E81.10

We recently released SandBlast Agent E81.10.

E81.10 introduces new features, stability and quality improvements.

A complete list of improvements can be found on the release Secure Knowledge sk155792 Enterprise Endpoint Security E81.10 Windows Clients.

 

Support for windows 10 19H1

E81.10 supports Windows 10 19H1 (version 1903), the latest version.

Please note that Anti-Malware support with Windows 10 19H1 requires a server hotfix. Please refer to sk141033 for more information.

 

Optimized Agent Package Size

E81.10 introduces 32-bit and 64-bit download packages for the Threat Prevention Client (SBA/Threat Prevention services and Anti-Malware).

The new package size is reduced from ~680MB to ~245MB.

Note that the Threat prevention package includes an initial set of Anti-Malware signatures. The complete set updates right after the client connects to the update server.

We continue to work on optimizing the package size and plan to introduce in the next releases even smaller package and dynamic updates which will improve dramatically the deployments package size. Stay tuned. J

 

BlueKeep (CVE-2019-0708)

Microsoft has announced that a critical vulnerability exists in Remote Desktop Services (RDS) relevant to several Windows products, including Windows 7 and Windows Server 2008 R2.

The vulnerability allows either Remote Code Execution or Denial of Service attacks when any unauthenticated user communicates with the machine.

SandBlast Agent Provide protection against BlueKeep vulnerability using SBA Anti-Exploit technology.

Additional information on how to protect against BlueKeep:

New Threat Emulation Report

E81.10 now supports by default the new Threat Emulation report with improved UI. Additional intelligence data enables better understanding of the malicious file and its effect on the machine.

The new report format has server version requirements:

  • All R80.30 versions are acceptable.
  • The R80.20 version must be R80.20M2 or R80.20 Jumbo Hotfix 4.
  • Customers who use server version 77.30.03 must use the SmartLog version released with Endpoint Security E80.92 or higher.