Create a Post
cancel
Showing results for 
Search instead for 
Did you mean: 
G_W_Albrecht
Legend
Legend

WLAN to LAN internal routing issue

This concerns a 1550 appliance running R80.20.30 firmware. I use LAN and WLAN, so i have configured a bridge:

LocalNets.png

My main MacBook is connected to LAN port 1, two other laptops and three iPhones to WLAN. All get an IP chosen by their MAC from between 10.0.0.2 and 10.0.0.14 ( one other devices can connect temporarily).

First part of the story: In summer, i have bought an Epson XP-6100 printer/scanner replacing a defective unit. It has no Ethernet port and only works over WLAN. So, i defined a Network Object with 10.0.0.14 as fixed IP. Now everything works as long as i use a device connected by WLAN to print or scan. From my main MacBook connected to a LAN, printing and scanning is impossible; i have to switch to WLAN connection to be able to do that.

Second part of the story: For nearly twenty years i have been using iTunes for my vast music collection. When sitting in the kitchen (iTunes MacBook is in the living room. loudspeakers in the kitchen get the living room signal by cable), i for years have used iTunes Remote to control the playlist, skip, change, stop a.o. without any issue. Approx. 1,5 years ago, this suddenly did work no longer - the iPhone showed my iTunes Media Center. but was unable to connect anymore. I did blame Apple as i thought they had changed something and found similar experiences in the Apple Support chats.

But after the Epson experience, i did research it more throughly and found out that iTunes Remote did in fact see my Media Center, iTunes on the MacBook did see my iTunes Remote app, but connection always failed, and that it will work flawlessly if i switch my iTunes MacBook to WLAN instead of LAN.

In the Logs, i only can see Accepts for the iPhone / iTunes MacBook connection although communication fails. So here are my questions:

Did anyone experience the same phenomenon and was able to resolve the issue ?

Was this introduced by a new SMB firmware version ?

Why does this happen at all although i use a bridge to have every device in the same local subnet ?

CCSE CCTE SMB Specialist
8 Replies
G_W_Albrecht
Legend
Legend

Nice to Kudo the post, but why ? If you have the same issue please just answer 😎

Anyone having a solution ? @Shlomi_Feldman , @Barel_Tkach , @Chris_Atkinson ?

CCSE CCTE SMB Specialist
0 Kudos
Chris_Atkinson
Employee
Employee

To clarify you have the "Allow station-to-station traffic" advanced option enabled for the WiFi ....

Do you see any difference with "Stateful Inspection - Perform deep packet inspection on LAN to LAN traffic" enabled and is the behavior unchanged with R80.20.35 ?

 

0 Kudos
G_W_Albrecht
Legend
Legend

Thank you for these suggestions ! Allow station-to-station traffic is enabled. Stateful Inspection - Perform deep packet inspection on LAN to LAN traffic is currently false, i can try to enable it in the evening. I have had some issues when changing firmware times ago so i still use R80.20.30 that works very well - do you think the issue will be resolved by R80.20.35 ? Maybe i could find out which firmware brought the issue, but as i always blamed Apple and not CP for it that is hard to do...

CCSE CCTE SMB Specialist
0 Kudos
Chris_Atkinson
Employee
Employee

Unfortunately I can't say for certain that R80.20.35 will change anything as I'm not currently in a position to replicate your setup, hence it's just a suggestion to eliminate.

 

0 Kudos
G_W_Albrecht
Legend
Legend

Stateful Inspection - Perform deep packet inspection on LAN to LAN traffic set to true does not resolve the issue. I will try R80.20.35 tomorrow...

CCSE CCTE SMB Specialist
0 Kudos
G_W_Albrecht
Legend
Legend

R80.20.35 installed shows the same issue. Strange thing is that iPhone iTunes Remote app and iTunes MacBook can see each other, but connection can only be established if both are connected to WLAN...

CCSE CCTE SMB Specialist
0 Kudos
G_W_Albrecht
Legend
Legend

Now the SMB team is involved and i hope that this issue can be resolved.

CCSE CCTE SMB Specialist
0 Kudos
G_W_Albrecht
Legend
Legend

I think i will have to contact TAC about this. Strange that no one has noticed this before.

CCSE CCTE SMB Specialist
0 Kudos