Create a Post
cancel
Showing results for 
Search instead for 
Did you mean: 
Chura
Explorer

VPN CLI Trac - User ignored

Hi,

Been using trac command_line for long time to connect my client VPN.

trac connect -u xxxx -p yyyy (Don't worry, password is a random token from variable :))

However, last few days, the user/pass is ignored, and i'm being asked to enter them interactively

 

Any suggestion ?

Running on mac with e84.30 (installed EA 84.70 as well now to test, same behaviour ) 

 

vpn.png

0 Kudos
9 Replies
PhoneBoy
Admin
Admin

“Wrong username or password” suggests incorrect credentials.
Do they work when logging in via the GUI?

Chura
Explorer

the username entered is just testing, I'd expect the trac take the username and passrod from the command line flags (-u -p) and not prompt for them interactively again.

0 Kudos
G_W_Albrecht
Legend
Legend

Any error in trac.log ?

0 Kudos
Chura
Explorer

Nope.

But I did notice something

If you look carefully, the logs above say that policy on gateway changed, then initiate new connection again. and the new connection doesn't take the variables.

What cause the policy change ? I've connected, to make sure I have the latest policy. Then disconnected and tried to connect from CLI and still saw "policy changed"

0 Kudos
G_W_Albrecht
Legend
Legend

And when connecting using EPS client GUI ?

0 Kudos
Chura
Explorer

Connecting fine, I enter my creds manually. 

BTW, if I enter them manually with "trac" it works fine as well.

0 Kudos
G_W_Albrecht
Legend
Legend

Strange - workaround would be a script that feeds the credentials to trac...

0 Kudos
Chura
Explorer

Yeah, I guess. but it doesn't feel right. 🙂

0 Kudos
G_W_Albrecht
Legend
Legend

Get TAC involved 😎

0 Kudos