cancel
Showing results for 
Search instead for 
Did you mean: 
Create a Post
Highlighted
Silver

Facing enormous issues while upgrading from R77.30.03 to R80.30

Hi Team,

I have Smart-1 210 with initially gone for On-prem Capsule DOCS & Capsule Workspace integrated with on-prem Exchange server. Even have installed Reverse proxy patch installed on mgmt appliance.

Now I have been struggling to upgrade as migrate export is giving me issues even after excluding epm db. Since later customer did not have used DOCS we stopped EPM blade and install database so hopefully, EPM must have de-activated.

But still, I am unable to take migrate export for the of-line upgrade. Even Pre-upgrade verifier is failing and I believe this is all due to EPM blade?

What is the other way as I do not have any redundancy for Mgmt server since that is an appliance.

Can someone please suggest?

******************

[Expert@xxxx-xxxx:0]# ./pre_upgrade_verifier -p $FWDIR -t R77 -t R80.30 -f output.txt
ReadFwsetFromSqlFile: 2 Error reading from database for file /opt/CPsuite-R77/fw1/conf/grc_test_elements.sqlite. Error is:

********************

Expert@xxxx-xxxxx:0]# ./migrate export xxx-xxxx.tgz
Execution finished with errors. See log file '/opt/CPshrd-R77/log/migrate-Sun_Jul__7_11-06-21_2019.log' for further details.

###################

[7 Jul 11:06:21] .<-- GetVersionString
[7 Jul 11:06:21] .--> UpgradeMacroReplacer::Instance
[7 Jul 11:06:21] .<-- UpgradeMacroReplacer::Instance
[7 Jul 11:06:21] .--> UpgradeMacroReplacer::Instance
[7 Jul 11:06:21] .<-- UpgradeMacroReplacer::Instance
[7 Jul 11:06:21] .--> ExecCommandGetOutput
[7 Jul 11:06:21] [ExecCommandGetOutput] Going to execute command: '"/opt/CPsuite-R77/fw1/bin/upgrade_tools/././pre_upgrade_verifier" -p "/opt/CPsuite-R77/fw1" -c 6.0.4.
0 -t 6.0.4.0'
[7 Jul 11:06:23] [ExecCommandGetOutput] ERR: Command completed with error code -1
[7 Jul 11:06:23] .<-- ExecCommandGetOutput
[7 Jul 11:06:23] [PreupgradeVerifierRunner::exec] ERR: Preupgrade verifier had failed
[7 Jul 11:06:23] [PreupgradeVerifierRunner::exec] Preupgrade verifier's output:
-------------------------------------
Plugin upgrade match command failed
Warning: Can't find ::CPSB-NGEP in cp.macro. License version might be not compatible


-------------------------------------
[7 Jul 11:06:23] <-- PreupgradeVerifierRunner::exec
[7 Jul 11:06:23] [ActivitiesManager::exec] ERR: Activity 'PreupgradeVerifierRunner' failed
[7 Jul 11:06:23] [ProgressUpdater::UpdateProgressToGaia] Progress Updated to '25
[7 Jul 11:06:23] [ActivitiesManager::exec] WRN: Activities execution finished with errors
[7 Jul 11:06:23] [ActivitiesManager::exec] WRN: Activities 'PreupgradeVerifierRunner' have failed
[7 Jul 11:06:23] [ActivitiesManager::exec] Designated exit code is 1

######################

 

 

 

 

 

0 Kudos
3 Replies
Highlighted
Employee+
Employee+

Re: Facing enormous issues while upgrading from R77.30.03 to R80.30

Hey,

Thank you for sharing your feedback with us.

It looks like an issue with pre-upgrade verifier which has failed to start.
"grc_test_elements.sqlite" file which could be corrupted.

We would like to help you, If you can please open a support ticket and share the number it will be great.

 

Regards,

Eyal

 

 

0 Kudos
Highlighted
Silver

Re: Facing enormous issues while upgrading from R77.30.03 to R80.30

I already did with local CCSP support but could not proceed after that. 

Can someone pls help?

0 Kudos
Highlighted
Employee+
Employee+

Re: Facing enormous issues while upgrading from R77.30.03 to R80.30

Hey,

You can share the SR number from our user center, at:

https://usercenter.checkpoint.com/usercenter/portal/media-type/html/role/usercenterUser/page/default...

As for our issue, the best and official way to proceed with this issue is to share a relevant support ticket 

We must involve TAC people for this.

Related to the problem itself – PUV fails due to some corruption in the grc_test_elements.sqlite file.

It can be replaced with a good one that can be taken from another machine. Of course, it should be from the same version.

 

Regards,

Eyal Magidish

0 Kudos