Create a Post
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted

Translate destination on client side

Hi CheckMates,

Per sk85460 says:

Detailed example: 

nat1.jpg

 

Server side scenario:

 2019-03-17_011421.png

If the correct static host/network route for "Destination/Server" was added into the routing table of the underlying operating system, the packet will be routed corrected to the outbound interface eth1.

I add 172.16.0.100 as below, but not work.

2019-03-17_010656.png

In this case, what routed I should add ?

 

0 Kudos
6 Replies
Highlighted
Admin
Admin

If the NAT IP is 172.16.0.100 and the real IP is 10.0.0.100, you would add a route for 172.16.0.100 with 10.0.0.100 configured as the nexthop.

That said, I'm not sure why you're doing this as the the default configuration (with Translate Destination on Client Side enabled) does not require a route like this.

Highlighted

Hi PhoneBoy,

 

I just LAB (Translate destination on client side / Translate destination on server side), because in this case (Translate destination on server side) I can not LAB success.

"If the correct static host/network route for "Destination/Server" was added into the routing table of the underlying operating system, the packet will be routed corrected to the outbound interface eth1."

0 Kudos
Highlighted
Admin
Admin

You add the route with the nexthop of an IP address, not an interface. The IP address will be on eth1, which will cause the traffic to be routed out eth1. Make sense?
0 Kudos
Highlighted

My Lab topology is show as below:

lab.png

I create 2 NAT rule :

nat rule.png

 

When translate on client side is check, I can revived web portal. fw monitor show as below:

fw monitor client.png

When translate on client side is uncheck, fw monitor show as below:

fw monitoe server.png

but O is not current, it should be eth0, show I add routing as below:

routing.png

fw monitor:

fw monitor add route.png

now it looks current interface, but still can't received web portal.

so I add web server second IP 10.8.2.80. and it is work. I can received web portal. fw monitor is show as below

fw monitor.png

 

In my lab, is it connection or route issue with access web portal even I add route?

or this is current configuration for this lab (translate on server side) ?

0 Kudos
Highlighted

My Lab topology is show as below:

lab.png

I create 2 NAT rule :

nat rule.png

 

When translate on client side is check, I can revived web portal. fw monitor show as below:

fw monitor client.png

When translate on client side is uncheck, fw monitor show as below:

fw monitoe server.png

but O is not current, it should be eth0, show I add routing as below:

routing.png

fw monitor:

fw monitor add route.png

now it looks current interface, but still can't received web portal.

so I add web server second IP 10.8.2.80. and it is work. I can received web portal. fw monitor is show as below

fw monitor.png

 

In my lab, is it connection or route issue with access web portal even I add route?

or this is current configuration for this lab (translate on server side) ?

0 Kudos
Highlighted
Pearl

Please remove this manual route and configure Static NAT in the properties of the Object of your server entering it's "Public" IP in the NAT tab.

This will create an automatic Proxy ARP entry on the "external" interface and will accept and forward traffic to the destination.

As far as routes go, both, Internal and External networks are going to be shown in your "Connected Routes".