Create a Post
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Participant

ECMP not working on Maestro

Hi,

As ISP redundancy is not working on R80.30SP, we tried configuring ECMP but it is also not working. Does anyone has any idea about how to perform ISP redundancy on Maestro. We have 2 ISP links. So configured 2 default gateways with priority 1 for both. When we disconnect one of the links, then traffic is not shifted over the other link. It shows network unreachable. 'show route' command displays both the default routes. Also tested with altering the priority, still not working. Below are the details of Setup.

Orchestrator: R80.20SP JHF_295

Maestro gateways: R80.30SP JHF_45

10 Replies
Highlighted
Employee++
Employee++

To confirm are you using ip-reachability with the routes, either ping or bfd?

Otherwise ECMP with BGP might be an option for you.

Highlighted
Participant

Hi Chris, We are using ip-reachability with ping. ECMP with BGP will be a difficult task as customer has to perform changes on ISP end.

0 Kudos
Reply
Highlighted
Employee++
Employee++

Understood, to confirm is this on Maestro configured for VSX ?

(ECMP for static routes on VSX isn't supported currently).

Highlighted
Participant

Hi Chris,

We are not using VSX but using Maestro R80.30SP.

0 Kudos
Reply
Highlighted
Employee++
Employee++

Hi Rohit,

I tested the following just now on a system with R80.20SP JHF T302

 

set static-route default nexthop gateway address 10.100.1.1 priority 1 on
set static-route default nexthop gateway address 10.100.1.4 priority 1 on
set static-route default ping on

 

How long did you leave the link disconnected?

 

Suggest you take this up with TAC to investigate further if sk169632 doesn't apply to your case.

0 Kudos
Reply
Highlighted
Participant

Hi Chris,

Thanks for your reply. Did it work in your environment? Also kindly let us know if you are using Orchestrator with gateways with R80.20SP or you are using 40k/64k appliance with R80.20SP.

To answer your query, we had kept the link disconnected for 10-15 min but no luck. We have raised a case tac and shared logs with them.

0 Kudos
Reply
Highlighted
Employee++
Employee++

Yes the routing worked, R80.20SP on Maestro with 6500 appliances.

0 Kudos
Reply
Highlighted
Participant

Hi Chris, Thanks for the update. We are having 7000 appliances and it seems that R80.20SP is not supported on 7000 appliances. We have checked installing R80.20SP with bootable USB but it shows driver issue.

0 Kudos
Reply
Highlighted
Employee++
Employee++

R80.30SP is the correct version for 7000 series appliances per sk162373.

0 Kudos
Reply
Highlighted
Participant

R&D team provided a package(attached below), which resolved the issue.

0 Kudos
Reply