cancel
Showing results for 
Search instead for 
Did you mean: 
Create a Post
Highlighted

Import SmartEvent Reports From NGSE to R80.10?

I have a dedicated SmartEvent server that is still running NGSE. I am in the process of planning the total migration of our Management environment (SMS, SMS HA Box, NGSE Reporting) to R80.10. It seemed to me the SmartEvent server was the best place to start.

We have a number of custom reports that were created under NGSE. I see an option to export these to .CPR files. On the R80.10 side, I see there is an option to import them as a Template. The import seems to complete, but I don't see these reports showing up in the list. 

Am I missing something? or is this possibly something that isn't supported to go from NGSE to R80.10? I'm not worried about losing the data, but I'd really like to avoid having to recreate these reports.

Thanks!

11 Replies
Employee+
Employee+

Re: Import SmartEvent Reports From NGSE to R80.10?

Hi Daniel,

Importing NGSE report templates to R80.10 is possible.

However, currently there is an issue with the import process and we are working to fix it.

You can edit the exported CPR files manually (XML file), and add the "catalogShow" flag after the <report> tag:

    <reports>

        <report>

            <catalogShow><![CDATA[true]]></catalogShow>

            <uid><![CDATA[{F1D93199-436A-418F-A248-BD55A03B9DE4}]]></uid>

 

If you prefer, you can send me the reports and I will do this procedure for you.

We hope to get it fixed in the next R80.10 JHF.

Re: Import SmartEvent Reports From NGSE to R80.10?

Thanks for the information. I tried editing one report and it seemed like it did show up in the list afterwards. 

However, since having done that, when I open a new tab under "Logs & Monitor", my client just sits saying "Loading SmartView..." and never brings up the typical menu that would load giving me options to choose logs / reports / etc... 

Is this a known symptom? Is there something I can do to fix it? 

Thanks!

0 Kudos
Employee+
Employee+

Re: Import SmartEvent Reports From NGSE to R80.10?

Can you try accessing the SmartView portal directly with your browser:

https://<ip>/smartview/

Are you able to login successfully?

Can you open a new tab?

If not, you may have corrupted the SmartView DB, and need to reset it.

run $RTDIR/scripts/stopSmartView
delete or rename the folder $RTDIR/smartview/db/
run $RTDIR/scripts/startSmartView

Would be helpful if you could attach the report file so I could examine it.

Thanks,

Kfir Dadosh

Re: Import SmartEvent Reports From NGSE to R80.10?

It looks like the SmartView portal was working properly through the web browser. However, the report I imported and modified the XML of did not show up there.

When I removed the SmartView DB and restarted the service, SmartView now works again inside the R80 Management Client and the imported report is now gone. 

So, it seems that something about importing the report corrupted the DB. Do you know if anyone else has observed this behavior? Is the best way to supply the report to just attach it here?

Thanks for getting me back up and operational!

0 Kudos
Employee+
Employee+

Re: Import SmartEvent Reports From NGSE to R80.10?

Did you connect to the same server (assuming SmartEvent and Management are running different machines)?

Maybe you added the report under a different admin?

Attach the modified report here, or send it directly to my email:

dadosh@checkpoint.com

Thanks,

Kfir Dadosh

0 Kudos

Re: Import SmartEvent Reports From NGSE to R80.10?

Kfir,

It has been a little while since I followed up on this thread. Do you know what the ETA for the fix you mentioned is? I still seem to have the same issue where once I modify the XML, my database gets corrupt and I have to reset it. 

Thanks for any advice you may have. Also, if this is a supported process, is it better if I open a SR with TAC?

Thank You,

Dan

0 Kudos

Re: Import SmartEvent Reports From NGSE to R80.10?

I was testing the import in my R80.10 test lab where Smart Event and Management are on the same machine. When I do the actual Production upgrade, they will run on different servers. 

I was logged in with the same user to both import the report and attempting to view it. 

I will send you a copy of the report via email.

Thank You!

-Dan

0 Kudos

Re: Import SmartEvent Reports From NGSE to R80.10?

Let's try posting it here

0 Kudos

Re: Import SmartEvent Reports From NGSE to R80.10?

Is there any update on this?  Has Check Point has fixed this issue?

Editing the CPR file worked for me.  It'll still be easier if we could just import them normally though.

0 Kudos
Employee+
Employee+

Re: Import SmartEvent Reports From NGSE to R80.10?

It should be fixed already.

0 Kudos

Re: Import SmartEvent Reports From NGSE to R80.10?

Hmm gotcha.  Was this addressed in a hotfix? 

Importing normally did not work for me.  It would say "import successfully completed" but then the custom report would not show up in the list of reports.  

It showed up only after I edited the CPR file and imported again.