cancel
Showing results for 
Search instead for 
Did you mean: 
Post a Question

vsec_central_license issue

Hi, I have a mixture of R77.30 and R80.10 Vsec gateways deployed in Azure. The R77.30 gateways have been running for over a year and I've not really had an issue deploying licenses to them using the vsec_central_license tool from the SMS (running R80.10).

However I have just introduced some R80.10 Vsec gateways in Azure and when I run the vsec_central_license  command it fails when trying to apply to an R80.10 gateway with the error "VSec - not R77.30". Obviously it isn't R77.30 , its R80.10. The hardware is set to open server and version R80.10 in smartconsole, I also tried changing the hardware to vsec but this made no difference. There are plenty of licenses spare to apply also.

Any ideas? thanks

0 Kudos
4 Replies

Re: vsec_central_license issue

Hi Alex,

maybe you could check this sk : sk81200 

0 Kudos

Re: vsec_central_license issue

Hi Luca, thanks for the response. Unfortunately sk81200 isn't applicable to Vsec licenses which need to be assigned via the vsec_central_license utility on the SMS.

Example below shows the command being run, successful attachment to R77.30 Vsec gateway, failure to R80.10 vsec gateways "not R77.30":

[Expert@SMS01]# vsec_central_license
vsec_central_license: is_license_lock_acquired: mutex lock count is not set.
Getting licenses from all modules ...
On-Prem-GW1- vsx object
On-Prem-GW2 - vsx object
VSec-GW1 - attaching licenses...

VSec-GW2 - not R77.30
[Expert@SMS01]#

0 Kudos

Re: vsec_central_license issue

Hi Alex,

I re-read better your scenario, you're right ... at this point, it would be better that you open a direct chat or a service request with the support.

it will probably be a quick thing...

0 Kudos

Re: vsec_central_license issue

Hi Luca, et all,

Checkpoint support provided the following answer which worked. Because I had upgraded my manager from R80 to R80.10 there were two instances of the vsec_central_license utility which was causing the issue. Renaming the old entry resolved the issue. code snippet below for anyone else who gets this issue:

Check if the vsec_central_license binary file appears twice on the R80.10 Management Server - once in the $VSECDIR/bin/ directory and once in the /bin/ directory:

[Expert@HostName]# stat $VSECDIR/bin/vsec_central_license

[Expert@HostName]# stat /bin/vsec_central_license

 

If this is the case, then run the following commands on the R80.10 Management Server:

[Expert@HostName]# cp -v $VSECDIR/bin/vsec_central_license{,_BKP}

[Expert@HostName]# mv -v /bin/vsec_central_license{,_BKP} [Expert@HostName]# mv -v $VSECDIR/bin/vsec_central_license /bin/vsec_central_license

 

Install database on the Management server and install policy on the R80.10 Gateways.

 

Then run the vsec_central_license command again.

cheers

Alex

0 Kudos