cancel
Showing results for 
Search instead for 
Did you mean: 
Post a Question

"Cannot run because the SmartUpdate ActiveX component corrupted or not registered" error when trying to open SmartUpdate

"Cannot run because the SmartUpdate ActiveX component corrupted or not registered" error when trying to open SmartUpdate

Anyone a solution? Cannot view the solution in user Center.

Thanks

0 Kudos
2 Replies

Re: "Cannot run because the SmartUpdate ActiveX component corrupted or not registered" error when trying to open SmartUpdate

Hi Ernie,

ActiveX component that is used by Smart Update is corrupted. You can uninstall, Reboot the machine and install Smart console again. Or you can refer below steps on client machine.

Open Command Prompt.
Go to the SmartConsole installation folder:
Windows 32-bit:
C:\> cd /d "C:\Program Files\CheckPoint\SmartConsole\R<XX>\PROGRAM"
Windows 64-bit:
C:\> cd /d "C:\Program Files (x86)\CheckPoint\SmartConsole\R<XX>\PROGRAM"
Register the ActiveX component:
C:\> regsvr32 isw_cfg.ocx MonitorCtrl.ocx
Open SmartUpdate GUI.
0 Kudos

Re: "Cannot run because the SmartUpdate ActiveX component corrupted or not registered" error when trying to open SmartUpdate

Hi, please make sure you open a ticket for this, we would like Check Point Support to investigate.

0 Kudos