Showing results for 
Search instead for 
Did you mean: 
Create a Post

Upgrade from R71.30 to R80.10

I was given the task to migrate a number of CMA's from a R71.30 MDS to our environment, which contains a number of Domains already. We need to do a gradual move (CMA's move 1 by 1) due to business requirements. So I looked at the R80.10 Upgrade/Download Wizard and see that I can use the following steps:

1. Upgrade from R71.30 to R75.20 :

R75.20 DVD Multi-Domain for SecurePlatform / RHEL 5.0 / RHEL 5.4

2. Upgrade from R75.20 to R77 :

R77 SecurePlatform/RHEL Fresh Install/Upgrade Package for Multi-Domain on Open Servers and Upgrade P...

3. Upgrade from R77 to R80.10 :

    Upgrade can only be done via Advanced Database Migration 

First problem you run into is the 20 year CA validity, which means you need to make sure to set the date back 1 or 2 years to make sure the CA can be created.

Then you are ready to migrate the CMA and guess what, when you try to migrate export the CMA from R75.20 to R77.30 you will be told it is not supported.

Ok then we just install a R75.40 MDS and use the same trick to make sure we have a CA (mdsconfig confirms there is one).

Now we create the new domain and try to import the exported file from R75.20 (which imported the R71.30 just fine) while creating the Domain management server I get this error:

Then when I click OK I run into the next error:

When I try to create the Domain management server separately I get the same error.

Why is this happening?

Tonight I will be trying a R76 MDS to see if I can import the R75.20

Regards, Maarten
4 Replies

Re: Upgrade from R71.30 to R80.10

1 thing just crossed my mind, is there a difference between R75.20 and R75.40 regarding the CA? the import on R75.20 works just fine but R75.40 fails on creating a CA, duhh.. But why is this version trying to create a CA while the previous did not do that?

I will try to set the date (which I reset to the current date before the import) back again to see if it then works ok, it probably will... We will see tonight.

Regards, Maarten
0 Kudos

Re: Upgrade from R71.30 to R80.10

R75.20 and R75.40 shouldn't have any differences in terms of creating the ICA.

That said, I suspect the issues are all related to the same issue with any management fresh-installed after 24th Jan 2018...

0 Kudos

Re: Upgrade from R71.30 to R80.10

If you're using virtual machines for new MDS, try disabling synchronization of time between ESX host and the guest machine. You can check what date-time is configured on R75.40 MDS right before importing CMA.

0 Kudos

Re: Upgrade from R71.30 to R80.10

Well yesterday I was still unable to connect to the R75.40 even after successfully creating the CA and setting the GuiClients to Any and adding my user to it, also a eval license was added and still no luck.

We also had a R76 MDS installed set it to 01-01-2018 and finally I was able to export the R75.20 with the R76 tools and import the resulting file into a new R76 domain.

From there you still can't go directly to R80.10 but we have a good R77.30 in between so that step will be taken from there.

So keep in mind to go from R71.30 to R80.10 takes 4 steps and a lot of work in installing and reworking in between systems, only 5 CMA's to go.

Regards, Maarten