Create a Post
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Silver

Upgrade R77.30 to R80.10 Database Import issue

Hi Team,

I am facing an issue while importing database for upgrade in R77.30. This is I am importing database from R77.30 to R77.30 and below is the error messages. Can someone pls help?

 

[24 Jun 11:39:29] [ExecCommandGetOutput] ERR: Command completed with error code 1
[24 Jun 11:39:29] ...<-- ExecCommandGetOutput
[24 Jun 11:39:29] [CommandRunner::exec] Command's output:
-------------------------------------

Execution finished with errors. See log file '/opt/CPshrd-R77/log/PItpi-import_install.elg' for further details
Execution has finished
-------------------------------------
[24 Jun 11:39:29] [CommandRunner::exec] ERR: Command execution had failed
[24 Jun 11:39:29] ..<-- CommandRunner::exec
[24 Jun 11:39:29] .<-- PluginsInstallationRunner::InstallPlugin
[24 Jun 11:39:29] [PluginsInstallationRunner::exec] ERR: Failed to install plugin
[24 Jun 11:39:29] <-- PluginsInstallationRunner::exec
[24 Jun 11:39:29] [ActivitiesManager::exec] ERR: Activity 'PluginsInstallationRunner' failed
[24 Jun 11:39:29] [ActivitiesManager::exec] WRN: Activities execution finished with errors
[24 Jun 11:39:29] [ActivitiesManager::exec] WRN: Activities 'PluginsInstallationRunner' have failed
[24 Jun 11:39:29] [ActivitiesManager::exec] Designated exit code is 1

**************************************************

[Expert@mgmt-server:0]# more /opt/CPshrd-R77/log/PItpi-import_install.elg
[24 Jun 11:39:24]
[24 Jun 11:39:24] *****************************************************************
[24 Jun 11:39:24] ********************* Log session beginning *********************
[24 Jun 11:39:24] *****************************************************************
[24 Jun 11:39:24] [writeExecCommandTolog] Program executed as: /opt/CPPItpi-R77/bin/uacRunner -p PItpi -import_install
[24 Jun 11:39:24] [writeEnvInfoToLog] Binary was build for Linux OS
[24 Jun 11:39:24] [writeEnvInfoToLog] Management type of machine is 'Smc'
[24 Jun 11:39:24] [writeOptionsToLog] Base name is: PItpi
[24 Jun 11:39:24] [writeOptionsToLog] Product name is: PItpi
[24 Jun 11:39:24] [writeOptionsToLog] Main run flag is: -import_install
[24 Jun 11:39:24] [writeOptionsToLog] Runner working directory is: /opt/CPPItpi-R77
[24 Jun 11:39:24] [writeOptionsToLog] Main run option is of type: Default
[24 Jun 11:39:24] [runDefaultActivities] Running default activities
[24 Jun 11:39:24] [PluginSpecs::PluginSpecs] Initializing plugin specs with '/opt/CPPItpi-R77/conf/specs.conf'
[24 Jun 11:39:24] [ActivitiesManager::exec] Starting activities execution
[24 Jun 11:39:24] [ActivitiesManager::exec] Executing activity 'PluginDefaultDbMaker'
[24 Jun 11:39:24] [copyPluginDBtoManagement] Removing directory '/opt/CPsuite-R77/fw1/conf/pluginDefault/_PItpi' if it exists
[24 Jun 11:39:24] [copyPluginDBtoManagement] Creating directory '/opt/CPsuite-R77/fw1/conf/pluginDefault/_PItpi'
[24 Jun 11:39:29] [copyPluginDBtoManagement] Copying plugin default directory from '/opt/CPPItpi-R77/conf/defaultDatabase' to '/opt/CPsuite-R77/fw1/conf/pluginDefault/_
PItpi'
[24 Jun 11:39:29] [copyPluginDBtoManagement] ERR: Failed to copy plugin default directory
[24 Jun 11:39:29] [ActivitiesManager::exec] ERR: Activity 'PluginDefaultDbMaker' failed
[24 Jun 11:39:29] [ActivitiesManager::exec] Rolling back previous activities
[24 Jun 11:39:29] [ActivitiesManager::exec] Rolling back activity 'PluginDefaultDbMaker'
[24 Jun 11:39:29] [ActivitiesManager::exec] WRN: Activities execution finished with errors
[24 Jun 11:39:29] [ActivitiesManager::exec] WRN: Activities 'PluginDefaultDbMaker' have failed
[24 Jun 11:39:29] [ActivitiesManager::exec] Designated exit code is 1

 

 

0 Kudos
10 Replies
Highlighted
Employee++
Employee++

Re: Upgrade R77.30 to R80.10 Database Import issue

Hi 

 

Did you have any Add-On installed on your source R77.30 Security Management?

This is usually related to mismatch between source and destination Security Management Servers.

 

HTH

Tal

0 Kudos
Highlighted
Employee++
Employee++

Re: Upgrade R77.30 to R80.10 Database Import issue

I also suggest referring to sk105412 - R77.30 Add-On - for additional information

 

Tal

 

0 Kudos
Highlighted
Silver

Re: Upgrade R77.30 to R80.10 Database Import issue

Yes I do have Add-on installed on Mgmt server. Does that mean I need to install the same Mgmt Add-on on Destination server?

 

0 Kudos
Highlighted
Employee++
Employee++

Re: Upgrade R77.30 to R80.10 Database Import issue

Yes they need to have the same Add-Ons installed
0 Kudos
Highlighted
Silver

Re: Upgrade R77.30 to R80.10 Database Import issue

Well How can I find previous version of R77.30 Add-on?

 

0 Kudos
Highlighted
Employee++
Employee++

Re: Upgrade R77.30 to R80.10 Database Import issue

sk105412 has all the relevant information including a link to the Download Center for the relevant package.

 

It should also be available from CPUSE.

 

Tal 

0 Kudos
Highlighted
Silver

Re: Upgrade R77.30 to R80.10 Database Import issue

Hello,

 

Nope I dont see any difference from source and destination machine? This seems to be something else.

Here is source machine

*****************

]0;admin@mgmt-server:~[Expert@mgmt-server:0]# [Expert@mgmt-server:0]# cpinfo -y all

------------------------
Hotfix versions
------------------------
[FW1]
HOTFIX_R77_30
HOTFIX_R77_30_JUMBO_HF

[SecurePlatform]
HOTFIX_R77_30_JUMBO_HF

[SmartPortal]
No hotfixes..

[Reporting Module]
HOTFIX_R77_30
HOTFIX_R77_30_JUMBO_HF

[SmartLog]
HOTFIX_R77_30

[PICPmgmtrfesR75]
No hotfixes..

[R7520CMP]
HOTFIX_R77_30

[R75CMP]
HOTFIX_R77_30

[NGXCMP]
HOTFIX_R77_30

[V40CMP]
HOTFIX_R77_30

[EdgeCmp]
HOTFIX_R77_30

[SFWCMP]
HOTFIX_R77_30

[FLICMP]
HOTFIX_R77_30

[CON66CMP]
No hotfixes..

[SFWR75CMP]
HOTFIX_R77_30

[PIsfwr75]
No hotfixes..

[CPinfo]
No hotfixes..

[PPACK]
HOTFIX_R77_30

[CPuepm]
HOTFIX_R77_30

[CVPN]
HOTFIX_R77_30

[R7540CMP]
HOTFIX_R77_30

[R7540VSCMP]
HOTFIX_R77_30

[R76CMP]
HOTFIX_R77_30

[SFWR77CMP]
HOTFIX_R77_30

[PItpi]
No hotfixes..

[PIscrub]
No hotfixes..

[rtm]
No hotfixes..

*********************************

And here is my dest machine-

[Expert@mgmt-server:0]# cpinfo -y all

This is Check Point CPinfo Build 914000173 for GAIA
[FW1]
HOTFIX_R77_30
HOTFIX_R77_30_JUMBO_HF

FW1 build number:
This is Check Point Security Management Server R77.30 - Build 009
Installed Plug-ins: R77.20 Add-on, R77.30 Add-on
This is Check Point's software version R77.30 - Build 048

[SecurePlatform]
HOTFIX_R77_30_JUMBO_HF

[CPinfo]
No hotfixes..

[SmartPortal]
HOTFIX_R77_30_JUMBO_HF

[Reporting Module]
HOTFIX_R77_30
HOTFIX_R77_30_JUMBO_HF

[CPuepm]
HOTFIX_R77_30
HOTFIX_R77_30_JUMBO_HF

[SmartLog]
HOTFIX_R77_30
HOTFIX_R77_30_JUMBO_HF

[SFWR77CMP]
HOTFIX_R77_30

[R7520CMP]
HOTFIX_R77_30

[R7540CMP]
HOTFIX_R77_30

[R7540VSCMP]
HOTFIX_R77_30

[R76CMP]
HOTFIX_R77_30

[R75CMP]
HOTFIX_R77_30

[NGXCMP]
HOTFIX_R77_30

[V40CMP]
HOTFIX_R77_30

[EdgeCmp]
HOTFIX_R77_30

[SFWCMP]
HOTFIX_R77_30

[FLICMP]
HOTFIX_R77_30

[CON66CMP]
No hotfixes..

[SFWR75CMP]
HOTFIX_R77_30

[CPUpdates]
BUNDLE_R77_30_JUMBO_HF

[DIAG]
HOTFIX_R77_30

[PItpi]
No hotfixes..

[PIscrub]
No hotfixes..

[rtm]
No hotfixes..

 

 

0 Kudos
Highlighted
Employee++
Employee++

Re: Upgrade R77.30 to R80.10 Database Import issue

The Destination machine is now the one with the Add-ons so they are not identical:

 

FW1 build number:
This is Check Point Security Management Server R77.30 - Build 009
Installed Plug-ins: R77.20 Add-on, R77.30 Add-on
This is Check Point's software version R77.30 - Build 048

 

Tal

0 Kudos
Highlighted
Silver

Re: Upgrade R77.30 to R80.10 Database Import issue

same as in Same version?
0 Kudos
Highlighted
Employee++
Employee++

Re: Upgrade R77.30 to R80.10 Database Import issue

Run cpinfo -y all to see exactly what's installed on the source machine and make sure you have the same installed on the destination machine.

You can use CPUSE to see the available downloads for your version.

0 Kudos