cancel
Showing results for 
Search instead for 
Did you mean: 
Create a Post

Unable to delete the gateway objects in R80.10

I created some gateways and then found out they were duplicated with the imported ones. The "delete" is grayed out When I tried to delete those gateways I created. The imported gateways seems normal. 

Does anyone else has the same issue while trying to delete the gateway objects?

Thanks,

Jessica

0 Kudos
7 Replies
Jerry
Platinum

Re: Unable to delete the gateway objects in R80.10

hi Jessica

simple solution would be to restart fwm (management) process and try to push the policy to the "working gw".

when done, try to remove the obsolete (orphaned) objects once not needed.

it is only a little glitch with postgreSQL DB on SMS/MGMT server I guess but once the gw object is created the topology should be created as well otherwise it isn't fully boarded into the DB.

hope it helps. otherwise please ask https://community.checkpoint.com/people/a5b2e7f3-09aa-32f8-96c2-f0f5bfa2988b - Tomer will help Smiley Happy 

Jerry
0 Kudos

Re: Unable to delete the gateway objects in R80.10

Hi Jerry, 

It is still a new server so I have no gateway attached for pushing policy yet.  I went to Checkpoint support and was advised to install from scratch. I was told by him the database is corrupt. 

I was using the Phython api scripts to import the policy package. 

Will update if anything new. 

Thanks, 

Jessica 

Highlighted
Admin
Admin

Re: Unable to delete the gateway objects in R80.10

You may be able to remove it from the API/CLI.

Try to list the gateways with show simple-gateways to see if it's there and use the delete simple-gateway command on the relevant gateway (by name or UID).

0 Kudos

Re: Unable to delete the gateway objects in R80.10

Thanks Dameon. I have been thinking to use API, however, with the indication from Checkpoint support, there might be a corrupt database. We tried the GuiDBedit and it shows the object is used by another session( which is not).

I actually created a new server from scratch trying to import the policy one more time.  

Will update...

0 Kudos
JozkoMrkvicka
Platinum

Re: Unable to delete the gateway objects in R80.10

I know there is way to "kick" that hidden opened session via some SQL query... Did it once and it helped. Will search for it later today.

By the way, what Jumbo you have installed ? Try the latest, maybe it can help.

Kind regards,
Jozko Mrkvicka
0 Kudos

Re: Unable to delete the gateway objects in R80.10

Looking forward to the "kick away"...

Yes it was the latest, take 169 I think? Unluckily, didn't work.