Create a Post
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted

R80.10 Upgrade

we try to upgrade from R77.30 to R8.10

i unable to execute the command in R80.10 test VM 

  we executing below command

cd /opt/CPsuite-R80/fw1/bin/upgrade_tools/migrate import /home/admin/1477099194_1o2_WIN-BBCVJ6QI1TP_9_11_2017_19_07_migrate_export_out

bash: cd: /opt/CPsuite-R80/fw1/bin/upgrade_tools/migrate_import: No such file or directory

please help us ...

Tags (1)
0 Kudos
Reply
10 Replies
Highlighted
Employee
Employee

Hi,

/opt/CPsuite-R80/fw1/bin/upgrade_tools/migrate is a binary and not a directory, therefore you can't use the 'cd' command on it.

The usage for the command is /opt/CPsuite-R80/fw1/bin/upgrade_tools/migrate import <path_to_file>

In your case, just drop the 'cd' at the begining:

/opt/CPsuite-R80/fw1/bin/upgrade_tools/migrate import /home/admin/1477099194_1o2_WIN-BBCVJ6QI1TP_9_11_2017_19_07_migrate_export_out

Kfir

Highlighted

Hi Kfir,

I am Facing below issue.

[Expert@gw-fba282:0]# /opt/CPsuite-R80/fw1/bin/upgrade_tools/R80.10/migrate import /home/admin/1477099194_1o2_WIN-BBCVJ6QI1TP_9_11_2017_19_07_migrate_export_out.tgz
The import operation will eventually stop all Check Point services (cpstop).
Do you want to continue? (y/n) [n]? y


Extracting the database...

Database export was done with migration tools for different version.
You must export and import database with migration tools for version
installed on destination machine.

Execution finished with errors. See log file '/opt/CPshrd-R80/log/migrate-2017.12.18_18.38.10.log' for further details

please help us on below issue.

Progress Updated to '25
[18 Dec 18:43:27] [ActivitiesManager::exec] Executing activity 'PluginPackCompatibilityChecker'
[18 Dec 18:43:27] --> PluginPackCompatibilityChecker::exec
[18 Dec 18:43:27] .--> UpgradeMacroReplacer::Instance
[18 Dec 18:43:27] .<-- UpgradeMacroReplacer::Instance
[18 Dec 18:43:27] .--> CanonicalizePath
[18 Dec 18:43:27] [CanonicalizePath] Canonicalizing path '/opt/CPsuite-R80/fw1/tmp/migrate//main_db/_plugin_upgrade_/'
[18 Dec 18:43:27] [CanonicalizePath] Resulting path: '/opt/CPsuite-R80/fw1/tmp/migrate//main_db/_plugin_upgrade_/'
[18 Dec 18:43:27] .<-- CanonicalizePath
[18 Dec 18:43:27] .--> UpgradeMacroReplacer::Instance
[18 Dec 18:43:27] .<-- UpgradeMacroReplacer::Instance
[18 Dec 18:43:27] .--> CanonicalizePath
[18 Dec 18:43:27] [CanonicalizePath] Canonicalizing path '/opt/CPsuite-R80/fw1/bin/upgrade_tools'
[18 Dec 18:43:27] [CanonicalizePath] Resulting path: '/opt/CPsuite-R80/fw1/bin/upgrade_tools/'
[18 Dec 18:43:27] .<-- CanonicalizePath
[18 Dec 18:43:27] .--> PluginPackCompatibilityChecker::GetPluginPackId
[18 Dec 18:43:27] [PluginPackCompatibilityChecker::GetPluginPackId] Reading plugin pack id information file located at '/opt/CPsuite-R80/fw1/tmp/migrate//main_db/_plugin_upgrade_/plugin_pack.conf'
[18 Dec 18:43:27] ..--> ReadFwsetFile
[18 Dec 18:43:27] ...--> UpgradeMacroReplacer::Instance
[18 Dec 18:43:27] ...<-- UpgradeMacroReplacer::Instance
[18 Dec 18:43:27] [ReadFwsetFile] Going to read file '/opt/CPsuite-R80/fw1/tmp/migrate//main_db/_plugin_upgrade_/plugin_pack.conf'
[18 Dec 18:43:27] [ReadFwsetFile] Succeeded to read file
[18 Dec 18:43:27] ..<-- ReadFwsetFile
[18 Dec 18:43:27] [PluginPackCompatibilityChecker::GetPluginPackId] Plugin pack id is: 'R77.30'
[18 Dec 18:43:27] .<-- PluginPackCompatibilityChecker::GetPluginPackId
[18 Dec 18:43:27] .--> PluginPackCompatibilityChecker::GetPluginPackId
[18 Dec 18:43:27] [PluginPackCompatibilityChecker::GetPluginPackId] Reading plugin pack id information file located at '/opt/CPsuite-R80/fw1/bin/upgrade_tools/plugin_pack.conf'
[18 Dec 18:43:27] ..--> ReadFwsetFile
[18 Dec 18:43:27] ...--> UpgradeMacroReplacer::Instance
[18 Dec 18:43:27] ...<-- UpgradeMacroReplacer::Instance
[18 Dec 18:43:27] [ReadFwsetFile] Going to read file '/opt/CPsuite-R80/fw1/bin/upgrade_tools/plugin_pack.conf'
[18 Dec 18:43:27] [ReadFwsetFile] Succeeded to read file
[18 Dec 18:43:27] ..<-- ReadFwsetFile
[18 Dec 18:43:27] [PluginPackCompatibilityChecker::GetPluginPackId] Plugin pack id is: 'R80.10'
[18 Dec 18:43:27] .<-- PluginPackCompatibilityChecker::GetPluginPackId
[18 Dec 18:43:27] [PluginPackCompatibilityChecker::exec] ERR: Plugin pack id on source machine is not identical to plugin pack id on destination machine
[18 Dec 18:43:27] .--> NotifyUser
[18 Dec 18:43:27] ..--> IsRunningInteractively
[18 Dec 18:43:27] ...--> GetConfig
[18 Dec 18:43:27] ...<-- GetConfig
[18 Dec 18:43:27] [IsRunningInteractively] Running interactively
[18 Dec 18:43:27] ..<-- IsRunningInteractively
[18 Dec 18:43:27] [NotifyUser] Running interractively, presenting a message to the user
[18 Dec 18:43:27] [NotifyUser] A message to the user is:
------------------------------------------------------------------

Database export was done with migration tools for different version.
You must export and import database with migration tools for version
installed on destination machine.
------------------------------------------------------------------
[18 Dec 18:43:27] .<-- NotifyUser
[18 Dec 18:43:27] <-- PluginPackCompatibilityChecker::exec
[18 Dec 18:43:27] [ActivitiesManager::exec] ERR: Activity 'PluginPackCompatibilityChecker' failed
[18 Dec 18:43:27] [ActivitiesManager::exec] WRN: Activities execution finished with errors
[18 Dec 18:43:27] [ActivitiesManager::exec] WRN: Activities 'PluginPackCompatibilityChecker' have failed
[18 Dec 18:43:27] [ActivitiesManager::exec] Designated exit code is 1
[18 Dec 18:43:27] --> CleanupManager::Instance
[18 Dec 18:43:27] <-- CleanupManager::Instance
[18 Dec 18:43:27] --> CleanupManager::DoCleanup
[18 Dec 18:43:27] [CleanupManager::DoCleanup] Starting to perform cleanup
[18 Dec 18:43:27] .--> DirCleaner::exec
[18 Dec 18:43:27] [DirCleaner::exec] Going to remove directory '/opt/CPsuite-R80/fw1/tmp/migrate/'
[18 Dec 18:43:37] .<-- DirCleaner::exec
[18 Dec 18:43:37] [CleanupManager::DoCleanup] Completed the cleanup
[18 Dec 18:43:37] <-- CleanupManager::DoCleanup

0 Kudos
Reply
Highlighted
Employee
Employee

Hi,

AFAIK when upgrading from R77.30 to R80.10 you need to use the upgrade tools of R80.10 both for import AND the export.

Make sure you export with the migration tools of the destination machine (in your case, R80.10)

Highlighted

HI kfir,

we run the per upgrade migration tools on both  R77.30 server and R80.10

again same error throwing ..

we followed below step by step process for upgrade. 

in R77.30 

cd /opt/CPsuite-R80/fw1/bin/upgrade_tools/R.80/

# tar -zxvf  Check_Point_R80_migration_tools_PreR80.Gaia.tgz

# ./per_uprade_verifier -p $FWIDR -c R77 -t R80

#cd /opt/CPsuite-R80/fw1/bin/upgrade_tools/R.80

#./migrate export /var/log/export-R77.30-to-R80.10.tgz

In R80.10

fresh installation in VM R80.10 gaia os

i copied migrate export file in R8.10 server path  /home/admin/

at-last we run this command.

#cpstop

#/opt/CPsuite-R80/fw1/bin/upgrade_tools/R80.10/migrate import /home/admin/export-R77.30-to-R80.10.tgz

same migration_tools executed  in both server .

kindly explain if any tools run  R80.10 server and share the links and commands.

0 Kudos
Reply
Highlighted
Employee
Employee

Hi,

On the new R80.10 machine, Instead of using /opt/CPsuite-R80/fw1/bin/upgrade_tools/R80.10/migrate, I think you should copy Check_Point_R80_migration_tools_PreR80.Gaia.tgz(the same tgz you used on the R77.30 machine), extract it and use the migrate tool from the tgz to import.

Also please make sure you are using the R80.10 Pre-R80 tools, and not the R80 Pre-R80 tools, as your tgz is Check_Point_R80_migration_tools_PreR80.Gaia.tgz, while the R80.10 tgz is Check_Point_R80.10_migration_tools_PreR80.Gaia.tgz

R80.10 Pre-R80 tools can be downloaded from sk111841 -  "Gaia Pre-R80 Tool" under "Additional Downloads and Products" section

0 Kudos
Reply
Highlighted

Hi kfir,

we want run same tools (Check_Point_R80.10_migration_tools_PreR80.Gaia.tgz) in both R77.30 and  R80.10 servers after we will export and import database from the servers.

but we run in R77.30 server R80 migration tool(Check_Point_R80_migration_tools_PreR80.Gaia.tgz) and R80.10 server run same version tool R80.10 (Check_Point_R80.10_migration_tools_PreR80.Gaia.tgz) may be that is issue .

thanks for you kind information.

kindly share any critical step while upgrading R77.30 to R80.10

0 Kudos
Reply
Highlighted

Yeah. Please use correct tool Check_Point_R80.10_migration_tools_PreR80.Gaia.tgz for the Up gradation process

0 Kudos
Reply
Highlighted

Hi Vinod,

I was also getting same error. "Database export was done with migration tools for different version"

Kindly Export the database with R80.10 Pre-verify tool properly and make sure that no errors on verification. It is good that you make folder in CD $FWDIR/bin - upgrade_tool1. copy R80.10 Pre-verify package in that folder (upgrade_tool1), extract it and do migrate export.

Now on new machine (Fresh R80.10 install), copy those .tgz package which you have exported. Please copy this package in CD $FWDIR/bin/upgrade_tools. And final step is try to import package with migrate import command.

0 Kudos
Reply
Highlighted

Hi,

Please check if the below article can help you to achieve your requirement.

Offline Migration/Upgrade of Management server from R77.30 Gaia to R80.10 Gaia | Award Winning Netwo... 

Thanks,

Vishnu.

0 Kudos
Reply
Highlighted
Employee+
Employee+

Hi Vinod,

I hope that following our help you to succeed with your migrating to R80.10
I appreciate if you share your experience with us in our R80.10 Survey 

if needed I will be happy to assist you with personal attention.

Eyal Rashelbach


R80 Desk Manager, Solution Center | Check Point Software Technologies

0 Kudos
Reply