cancel
Showing results for 
Search instead for 
Did you mean: 
Post a Question

Mgmt_CLI command fails when using 'send-logs-to-server' function

So im trying to modify the log server set on a specific gateway using the mgmt_cli command on my R80.10 Smart-1 Mgmt server and I keep getting the following error:

DC1-XXXX-MGMT01> mgmt_cli set simple-gateway name DC1-XXX-DEV-XXXFW01 send-logs-to-server add DC2-XXXX-MGMT01
MGMT9000 Error: The parameters of set-simple-gateway command should be provided in pairs (key and value). You have provided an odd number of parameters which suggests that you are probably missing a parameter.

I looked through the Mgmt CLI documentation but cannot find any guidance on the use of that command.

3 Replies
Employee+
Employee+

Re: Mgmt_CLI command fails when using 'send-logs-to-server' function

If you run it without the "add" command, does it work as expected?

mgmt_cli set simple-gateway name DC1-XXX-DEV-XXXFW01 send-logs-to-server add DC2-XXXX-MGMT01

0 Kudos

Re: Mgmt_CLI command fails when using 'send-logs-to-server' function

Tried that aswell and I get the following error. Based on the Mgmt_cli documentation it seems like the add/remove argument is required.

DC1-XXXXXX-MGMT01> mgmt_cli set simple-gateway name DC1-XXX-DEV-XXXXFW01 send-logs-to-server DC2-XXXX-MGMT01
MGMT9000 code: "generic_error"
message: "Runtime error: Unmarshalling Error: Unable to create an instance of com.checkpoint.management.dlecommon.ngm_api.CpmiOwned "

0 Kudos
Employee+
Employee+

Re: Mgmt_CLI command fails when using 'send-logs-to-server' function

That's an error I haven't seen before, but it has been posted previously here on the site. I would have support take a look as this might be a known issue.