Create a Post
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Explorer

Issues with a scheduled backup

Hello guys,

 

I have a customer who is having troubles when the scheduled backup is running. Sometimes it works and sometimes it doesn´t. The partition is around 66% so it is not a /var/log partition problem. As per the sk121212, it might be the TAR version 1.26 who is caussing issues and it suggests to downgrade the version to 1.15.1. The thing is that it does not say how to do it. Can someone knows the proceed to do it? Thank you and regards. 

0 Kudos
7 Replies
Highlighted
Admin
Admin

Precisely how is this backup being triggered?
By what mechanism?
0 Kudos
Highlighted
Explorer

Hello PhoneBoy,

 

It is a scheduled backup configured once a week in the web portal. 

0 Kudos
Highlighted
Leader
Leader

Hello varo08,

are you asking about backup of SMS?

Please be aware that there should be no sessions with logged in administrators. The backup does not run in this case, hey are locking the database.

Have a look at the logfiles in /var/log/CPbackup why the backup is failing.

Wolfgang

0 Kudos
Highlighted
Explorer

Hello Wolfgang,

 

Yes it is a Security Managent Server. The backup is running in the morning when no one is log in into the SMS. I have checked the logs that you refered but I no root cause is shown: 

Tue Feb 11 02:30:41 2020]: Info: 'generic_backup': Executing <tar -C /lvsnap -zcvf backup_fwsgbt1_11_Feb_2020_02_30.tgz --ignore-failed-read --no-recursion -T /tmp/temp_tar_include_23942.txt1 2>&1>
[Tue Feb 11 02:31:33 2020]: Info: 'generic_backup': Execution Failed. <Exit Code=1>
[Tue Feb 11 02:31:33 2020]: Error: 'change_to_root_dir': Cannot change to directory /var/log/CPbackup/backups
: No such file or directory

[Tue Feb 11 02:31:33 2020]: Cannot complete the backup process due to package compression errors.
[Tue Feb 11 02:31:34 2020]: Info: 'unlock': Removing </var/CPsnapshot/tmp/cpbackup_util_23942.lock> ..
[Tue Feb 11 02:31:34 2020]: Info: 'is_full_lv': Executing <lvs -o snap_percent --noheadings /dev/vg_splat/lv_current_snap 2>/dev/null>
[Tue Feb 11 02:31:34 2020]: Info: 'is_full_lv': /dev/vg_splat/lv_current_snap percent is : 0.04
[Tue Feb 11 02:31:34 2020]: Info: 'is_full_lv': /dev/vg_splat/lv_current_snap is not full
[Tue Feb 11 02:31:34 2020]: Info: 'umount_dir': Executing <mountpoint /lvsnap 2>&1>
[Tue Feb 11 02:31:34 2020]: Info: 'umount_dir': Executing <umount /lvsnap 2>&1>
[Tue Feb 11 02:31:34 2020]: Info: 'umount_dir': unmount /lvsnap succeeded
[Tue Feb 11 02:31:34 2020]: Info: 'remove_snapshot_lv': Executing <lvremove -f /dev/vg_splat/lv_current_snap 2>&1>
[Tue Feb 11 02:31:34 2020]: Info: 'remove_snapshot_lv': remove /dev/vg_splat/lv_current_snap succeeded
[Tue Feb 11 02:31:34 2020]: Backup operation failed.

 

 

Thank you 

0 Kudos
Highlighted
Admin
Admin

Ok, so does /var/log/CPbackup/backups exist on your system?
0 Kudos
Highlighted
Explorer

It does. This issue happens once in a while, sometimes the backup is created well and sometimes it gives that error.

0 Kudos
Highlighted
Explorer

Good Morning:

It's my 1st post in this community.. well, i have same problem like Varo08 with Scheduled Backups. Before yesterday Backup was done without any problem, but yesterday didn't work.

I add an screenshot from logs with the final sentence of the process.

it 's posible to have an issue with compression program but why randomly days works?

Any SK o Recommendation to do?

Backup_Failed 21-05-2020.jpg

King Regards.

0 Kudos