cancel
Showing results for 
Search instead for 
Did you mean: 
Post a Question
Vladimir
Jade

IPS Blade License activation on Standby Member of HA Cluster

I believe there was a post earlier about users experiencing issues with this, but I could not locate the thread.

So from my recent experience:

All the subscription based blades could not be licensed offline, only Firewall and IPsec VPN blades were.

Licenses and contracts were downloaded and applied via SmartUpdate, (to be precise, in R80.10 it is an executable SmartDistributor.exe).

Once cluster was brought online and the Internet connectivity was established, most blades' licenses were activated with the exception of IPS on a Standby node.

I also recall reading that for some users this was mysteriously resolved after indeterminate amount of time.

To make that interval shorter, I've failed-over from active to standby member and the licence was updated within an hour.

The message I was seeing: 

  • Cannot fetch license information due to a configuration error. Refer to sk114615 with error ID: <7>(Error ID 7: Could not resolve host)

Was not reflective of the actual behavior of the standby member.

Tags (2)
0 Kudos
3 Replies
Neil_ZInk
Copper

Re: IPS Blade License activation on Standby Member of HA Cluster

I had this same issue.  Chances are the standby member cannot access the internet please check out Sk34180

0 Kudos
Vladimir
Jade

Re: IPS Blade License activation on Standby Member of HA Cluster

I suspect that this is not it: There are other blades' licenses that require connectivity for activation. App Control and URLF, AV. Anti Bot, etc., those were activated successfully.

I had also tested ICMP to the Internet based hosts from the standby member and it was succeeding.

So I am uncertain if changing standby to active solved the issue, or it would have happen regardless in time.

0 Kudos

Re: IPS Blade License activation on Standby Member of HA Cluster

You should be able to pinpoint the issue using CLI

# cplic print

on the GWs. When installing licence and Service Contract file using SmartUpdate, sometimes there are troubles with the Service Contract file. Then you have to transfer the Service Contract file to the GW and install it using CLI:

# cplic contract put -o <file name>.xml

0 Kudos