Create a Post
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted

Having problem with my clusterXL: Error message "HA module not started" after cphaprob stat.

Jump to solution

Cluster XL is enabled using cpconfig

#cphaprob stat

HA module not started

Tags (1)
1 Solution

Accepted Solutions
Highlighted

Re: Having problem with my clusterXL: Error message "HA module not started" after cphaprob

Jump to solution
 

If you forgot to select "install ClusterXL" in the wizard, you must  install the gateway again.

Also a possible cause:

Cluster membership was not enabled completely on the problematic machine.

Solution:

Perform the following steps in order to make sure that cluster membership is enabled on the problematic machine:

  1. Run cpconfig command in expert mode and choose 'Disable cluster membership for this gateway'.

  2. Reboot the machine:

    # reboot

  3. Run cpconfig command in expert mode  and  choose 'Enable cluster membership for this gateway'.

  4. Reboot the machine:

    # reboot

If that doesn't help, here's what you need to do also:

  1. Now reset SIC and initialize SIC via cpconfig new.

  2. Now install the policy from SmartConsole

Now check the cluster state via cphapro stat

If this does not help, execute the following SK:
- sk109755
- sk88360
- sk151952
- sk110573

View solution in original post

Tags (1)
10 Replies
Highlighted
Employee+
Employee+

Re: Having problem with my clusterXL: Error message "HA module not started" after cphaprob stat.

Jump to solution

To start

#cpha start

Make sure it is configured to start at boot based on cpconfig

#cpconfig

Select option to "Enable cluster membership for this gateway"

If is says disable it is already enabled.

Also, make sure policy is installed that deems this box is a cluster member.

Highlighted

Re: Having problem with my clusterXL: Error message "HA module not started" after cphaprob stat.

Jump to solution

probably your gateway need a policy firewall where it say that he is part of a cluster too

Highlighted

Re: Having problem with my clusterXL: Error message "HA module not started" after cphaprob stat.

Jump to solution

Hi guys, error persists...

Any other suggestions??

0 Kudos
Highlighted

Re: Having problem with my clusterXL: Error message "HA module not started" after cphaprob stat.

Jump to solution

During first time wizard did you check unit is a part of a cluster? what is the output of fw stat?

If you have done (checking unit is a part of a cluster) and you have configured a check point cluster object correctly on the management server with a security policy  I suggest to open a tac issue or contact your local partner

Highlighted
Nickel

Re: Having problem with my clusterXL: Error message "HA module not started" after cphaprob

Jump to solution
Hi,

What if I did not enable ClusterXL during the Gaia First Time Configuration Wizard? Is there other ways to install or enable ClusterXL?
0 Kudos
Highlighted
Nickel

Re: Having problem with my clusterXL: Error message "HA module not started" after cphaprob stat.

Jump to solution

have you checked if the coreXL configuration is the same on the cluster members?

if enabled or not, if the number of "fw instance" is equal between members.

0 Kudos
Highlighted

Re: Having problem with my clusterXL: Error message "HA module not started" after cphaprob stat.

Jump to solution

I assume that both gateways are identical (appliances, corexl config, software versions etc) and you have configured gateways correctly as a cluster member at first time wizard, and also you have a regular gateway license. Run cpconfig command  choose 'enable cluster membership for this gateway', exit from cpconfig menu and reboot the machine. Install policy gateways and then check the status again.

Highlighted
Ivory

Re: Having problem with my clusterXL: Error message "HA module not started" after cphaprob

Jump to solution

I assume that both gateways are identical (appliances, corexl config, software versions etc) and you have configured gateways correctly as a cluster member at first time wizard, and also you have a regular gateway license. Run cpconfig command  choose 'enable cluster membership for this gateway', exit from cpconfig menu and reboot the machine. Install policy gateways and then check the status again "

 

The solution above work for me. I just had to install the policy, and after that my cluster went Up. Thanks

Highlighted

Re: Having problem with my clusterXL: Error message "HA module not started" after cphaprob

Jump to solution
 

If you forgot to select "install ClusterXL" in the wizard, you must  install the gateway again.

Also a possible cause:

Cluster membership was not enabled completely on the problematic machine.

Solution:

Perform the following steps in order to make sure that cluster membership is enabled on the problematic machine:

  1. Run cpconfig command in expert mode and choose 'Disable cluster membership for this gateway'.

  2. Reboot the machine:

    # reboot

  3. Run cpconfig command in expert mode  and  choose 'Enable cluster membership for this gateway'.

  4. Reboot the machine:

    # reboot

If that doesn't help, here's what you need to do also:

  1. Now reset SIC and initialize SIC via cpconfig new.

  2. Now install the policy from SmartConsole

Now check the cluster state via cphapro stat

If this does not help, execute the following SK:
- sk109755
- sk88360
- sk151952
- sk110573

View solution in original post

Tags (1)

Re: Having problem with my clusterXL: Error message "HA module not started" after cphaprob

Jump to solution
 

If you forgot to select "install ClusterXL" in the wizard, you must  install the gateway again.

Also a possible cause:

Cluster membership was not enabled completely on the problematic machine.

Solution:

Perform the following steps in order to make sure that cluster membership is enabled on the problematic machine:

  1. Run cpconfig command in expert mode and choose 'Disable cluster membership for this gateway'.

  2. Reboot the machine:

    # reboot

  3. Run cpconfig command in expert mode  and  choose 'Enable cluster membership for this gateway'.

  4. Reboot the machine:

    # reboot

If that doesn't help, here's what you need to do also:

  1. Now reset SIC and initialize SIC via cpconfig new.

  2. Now install the policy from SmartConsole

  3. Now check the cluster state via cphapro stat


If this does not help, execute the following SK:
- sk109755
- sk88360
- sk151952
- sk110573

 

 


Tags (1)
0 Kudos