Create a Post
cancel
Showing results for 
Search instead for 
Did you mean: 
Contributor

Command Line Arguments to R80.10 SmartConsole.exe

Jump to solution

Hello,

we used to launch SmartDashboard up to R77.30 for different SmartCenters from , a tool to manage connections to all kinds of devices. We launched "FwPolicy.exe connect %Hostname% %Username%".

However, on R80.10, FwPolicy.exe is no longer the right binary to launch. We discovered that we need to run , which does not seem to accept any command line arguments.

Is there a way to pass Username and Hostname to this or another binary to support directly launching a SmartDashboard for R80.10?

regards, Arne

1 Solution

Accepted Solutions

Yes this is possible (and undocumented..sorry about that...)

See the attached file. You have to unzip it before use. It is called SmartConsole.LoginParams but you can change it to any name you like as long as it appears in the -p value below:

SmartConsole.exe -p SmartConsole.LoginParams

SmartConsole.LoginParams 

Format of the XML (none of these parameters is mandatory):

<?xml version="1.0" encoding="utf-8"?>
<RemoteLaunchParemeters xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xmlns:xsd="http://www.w3.org/2001/XMLSchema">
<Username>aa</Username>
<ServerIP>10.10.2.54</ServerIP>
<DomainName>LondonDomain</DomainName>
<ReadOnly>False</ReadOnly>
<CloudDemoMode>False</CloudDemoMode>
<DomainName>LondonDomain</DomainName>
</RemoteLaunchParemeters>

View solution in original post

10 Replies

Yes this is possible (and undocumented..sorry about that...)

See the attached file. You have to unzip it before use. It is called SmartConsole.LoginParams but you can change it to any name you like as long as it appears in the -p value below:

SmartConsole.exe -p SmartConsole.LoginParams

SmartConsole.LoginParams 

Format of the XML (none of these parameters is mandatory):

<?xml version="1.0" encoding="utf-8"?>
<RemoteLaunchParemeters xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xmlns:xsd="http://www.w3.org/2001/XMLSchema">
<Username>aa</Username>
<ServerIP>10.10.2.54</ServerIP>
<DomainName>LondonDomain</DomainName>
<ReadOnly>False</ReadOnly>
<CloudDemoMode>False</CloudDemoMode>
<DomainName>LondonDomain</DomainName>
</RemoteLaunchParemeters>

View solution in original post

Contributor

Hello Tomer,

thanks for the quick response. I have some suggestions to improve useability:

1. there is a typo in "RemoteLaunchParemeters" - maybe this should be corrected in the code and sample?

2. On a non-mds I had to leave the "DomainName" field empty

3. Now, after Launch, I receive an error message that password may not be empty. Is there a way to skip this error message and drop me directly to the usual login screen?

regards, Arne

1. You are correct

2. Yes. You can also just delete that node

3. Understandable. We will consider this for one of our next builds or releases.

<Password>xyz</Password>

also works!

Regards,

Heiko

Employee+
Employee+

Tomer, 

 

Do we have same option for EndpointManager.exe ? R80.40 and above

Regards, 

Alec

 

0 Kudos
Reply
Admin
Admin

As far as I know this should still work the same way in current versions.

0 Kudos
Reply
Employee+
Employee+

Thank You Dameon, 

 

will give it a try

 

/Alec

0 Kudos
Reply
Employee+
Employee+

Hello again, 

 

seems that Endpointmanager.exe is not picking up parameters file...so connection parameters are not passed to application.

 

/Alec

0 Kudos
Reply
Champion
Champion

Only Dashboard reads the parameter file, but you can use Dashboard to open Endpoint...

0 Kudos
Reply
Employee+
Employee+

Please ellaborate how can i do it via CLI?

0 Kudos
Reply