cancel
Showing results for 
Search instead for 
Did you mean: 
Post a Question

CMA import fails to R80

Hiya

Sorry if this type of question is already answered on this forum.

I am a bit confused and hope you guys can help me.

I have done a lot of CMA migration from 77 to 80.10 but never had any issues, but recently while doing another CMA migration from 77 to 80.10 I had encountered below issue.


Background:

I have removed global policy and I migrated only the standard policy.

But its not working, I tried am getting below error at the end of the log.


[10 May 11:53:12] [CanonicalizePath] Canonicalizing path '/opt/CPmds-R80/customers/AMAZON_MS/CPsuite-R80/fw1/bin/'
[10 May 11:53:12] [CanonicalizePath] Resulting path: '/opt/CPmds-R80/customers/AMAZON_MS/CPsuite-R80/fw1/bin/'
[10 May 11:53:12] ....<-- CanonicalizePath
[10 May 11:53:12] ....--> DbUpgrader::GetDestMainDbVersion
[10 May 11:53:12] .....--> MigrateConfig::Instance
[10 May 11:53:12] .....<-- MigrateConfig::Instance
[10 May 11:53:12] .....--> MigrateConfig::GetConfigSet
[10 May 11:53:12] .....<-- MigrateConfig::GetConfigSet
[10 May 11:53:12] .....--> GetVersionString
[10 May 11:53:12] ......--> IsVersionSetValid
[10 May 11:53:12] ......<-- IsVersionSetValid
[10 May 11:53:12] .....<-- GetVersionString
[10 May 11:53:12] ....<-- DbUpgrader::GetDestMainDbVersion
[10 May 11:53:12] ...<-- DbUpgrader::BuildMainDbUpgradeCommand
[10 May 11:53:12] ...--> DbUpgrader::ExecuteCpdb
[10 May 11:53:12] [DbUpgrader::ExecuteCpdb] Executing cpdb using the following arguments: "/opt/CPmds-R80/customers/AMAZON_MS/CPsuite-R80/fw1/bin/cpdb" up --no-ngm-db-drop --no-ngm-stop --src_version 6.0.4.0 --src_hfa_level 10 --src_path "/opt/CPmds-R80/customers/AMAZON_MS/CPsuite-R80/fw1/tmp//export_db/main_db/" --db_path "/opt/CPmds-R80/customers/AMAZON_MS/CPsuite-R80/fw1/conf/" --default_path "/opt/CPmds-R80/customers/AMAZON_MS/CPsuite-R80/fw1/conf/defaultDatabase" --db_type cma --db-migration
[10 May 11:53:12] [runShellCommand] Executing command: '"/opt/CPmds-R80/customers/AMAZON_MS/CPsuite-R80/fw1/bin/cpdb" up --no-ngm-db-drop --no-ngm-stop --src_version 6.0.4.0 --src_hfa_level 10 --src_path "/opt/CPmds-R80/customers/AMAZON_MS/CPsuite-R80/fw1/tmp//export_db/main_db/" --db_path "/opt/CPmds-R80/customers/AMAZON_MS/CPsuite-R80/fw1/conf/" --default_path "/opt/CPmds-R80/customers/AMAZON_MS/CPsuite-R80/fw1/conf/defaultDatabase" --db_type cma --db-migration'
[10 May 11:53:14] [runShellCommand] Execution result: 1, exit code: -1
[10 May 11:53:14] [DbUpgrader::ExecuteCpdb] ERR: cpdb completed with error code '-1'
[10 May 11:53:14] ...<-- DbUpgrader::ExecuteCpdb
[10 May 11:53:14] ..<-- DbUpgrader::UpgradeMainDatabase
[10 May 11:53:14] [DbUpgrader::exec] ERR: Failed to upgrade main database
[10 May 11:53:14] .<-- DbUpgrader::exec
[10 May 11:53:14] <-- ConditionalExecutor::exec
[10 May 11:53:14] [ActivitiesManager::exec] ERR: Activity 'ConditionalExecutor' failed
[10 May 11:53:14] [ProgressUpdater::UpdateProgressToGaia] Progress Updated to '66.6667
[10 May 11:53:14] [ActivitiesManager::exec] WRN: Activities execution finished with errors
[10 May 11:53:14] [ActivitiesManager::exec] WRN: Activities 'ConditionalExecutor' have failed
[10 May 11:53:14] [ActivitiesManager::exec] Designated exit code is 1
[10 May 11:53:14] --> CleanupManager::Instance
[10 May 11:53:14] .--> CleanupManager::CleanupManager
[10 May 11:53:14] .<-- CleanupManager::CleanupManager
[10 May 11:53:14] <-- CleanupManager::Instance
[10 May 11:53:14] --> CleanupManager:oCleanup
[10 May 11:53:14] [CleanupManager:oCleanup] Starting to perform cleanup
[10 May 11:53:14] [CleanupManager:oCleanup] Completed the cleanup
[10 May 11:53:14] <-- CleanupManager:oCleanup


Any help would be appreciated.

Jessica

0 Kudos
3 Replies
Admin
Admin

Re: CMA import fails to R80

Some of the SKs I've seen on this suggest some part of your database is corrupted.

You may wish to engage with the TAC to assist: Contact Support | Check Point Software 

0 Kudos

Re: CMA import fails to R80

thanks , can you share the SK please which suggest its due to corrupted database?

0 Kudos
Admin
Admin

Re:  CMA import fails to R80

The SKs I saw were internal.

Either way, the TAC should be consulted.

0 Kudos