Showing results for 
Search instead for 
Did you mean: 
Create a Post

CDT v1.6 is GA!

Hi all,

I am very happy to announce the release of version 1.6 of the CDT - Central Deployment Tool, which now also supports VSX.

Version 1.6 introduces the following new features, as well as bug fixes and minor additions:

  • VSX support – including gateways, HA clusters and VSLS clusters
  • Customized RMA backup & restore - add additional files to the backup
  • Resume mode – quickly resume after resolving issues with failed deployment plans
  • CloudGuard support - Gateways and CloudGuard Controllers R80.10 and above


Version 1.6 will also be included in version releases starting R80.30 on all Security Management and Multi-Domain Management machines.


Please visit sk111158 for download and usage instructions.

Any comments or suggestions for CDT will be appreciated!

6 Replies

Re: CDT v1.6 is GA!

Hi Arik,

I having some troubles updating 5600 cluster from 77.30 to 80.10 using CDT 1.6

it worked fine with the 3200 and 5400

did hear about any similar problems

0 Kudos

Re: CDT v1.6 is GA!

TAC case, TAC case..
0 Kudos

Re: CDT v1.6 is GA!

The documentation at needs to be updated.


In the section "Generating an Installation Candidates List" it notes the following steps to generate a candidate list:


# mdsenv <IP Address or Name of Domain Management Server>

# ./CentralDeploymentTool -generate <Name of Candidates List file>.csv <IP Address or Name of Domain Management Server>

I switch to the environment I want to generate a list for.  And then I issue the command:

./CentralDeploymentTool -generate mylist.csv MyDMS

And CDT replies with Invalid number of arguments.  It does not matter if I use the name or IP for my MDS.


Switching over to advanced mode, it seems to be a little happier with the syntax.  But since I don't have a deployment plan (or a an example of a basic plan to just collect data) it yells at me about that.


The syntax that the tool offers as a part of the error message is:

-generate -candidates=<file name> -deploymentplan=<filename.xml> [-server=<Domain Management Server IP>] [-filter=<file name>]

When I use the -candidates to generate the list it looks like it takes it out of basic mode and ends up wanting a deployment plan.

0 Kudos

Re: CDT v1.6 is GA!

Hi folks,

I guess I run into the same issue as Tommy did... Any solution? Thx in advance!

0 Kudos

Re: CDT v1.6 is GA!

Hello Tommy,

I  was having similar problem . If you're running a MDS environment please try to use the following command and see if it will make any difference:

./CentralDeploymentTool -generate -candidates=NAME.csv -deploymentplan=my_deployment_plan.xml -server=CMA_IP 

I think the problem is coming if you're using the MDS name/ip instead of the CMA name/ip.


0 Kudos

Re: CDT v1.6 is GA!

Any reason why I cannot access that SK? I try accessing from my Employer User Center login and I get a lock on that SK.
0 Kudos