cancel
Showing results for 
Search instead for 
Did you mean: 
Post a Question

VPN & fwconn_key_init_links (OUTBOUND) failed

Hi Checkmates,

We are working on a migration project and we are facing a strange issue.

The architecture is quite simple :

- Cluster of 5800 appliances, R80.10 + jumbo 154

- Management is a R80.10 VM.

Everything seems fine except VPN. Only 4 VPN amongs 7 are working. Not always the same, but never more than 4.

For the failed VPNs, we've discovered that outgoing IKE packet are dropped by the active member :

;[cpu_7];[fw4_0];fw_log_drop_ex: Packet proto=17 a.a.a.a:500 -> b.b.b.b:500 dropped by fw_conn_post_inspect Reason: fwconn_key_init_links (OUTBOUND) failed;

a.a.a.a : cluster IP

b.b.b.b : peer IP

We have contacted the TAC and they've collected multiples captures. For now, nobody seems to be able to explain why the gateway drops its own IKE packets.

According to TAC, sk124732 doesn't applied.

If anyone knows what "fwconn_key_init_links (OUTBOUND) failed" could means ...

Thanks for your help !

Tags (2)
4 Replies
Admin
Admin

Re: VPN & fwconn_key_init_links (OUTBOUND) failed

The error message seems to be NAT related, specifically when the attempt to NAT fails for one reason or another.

It comes up here (among other places): Traffic is not NATed correctly 

0 Kudos

Re: VPN & fwconn_key_init_links (OUTBOUND) failed

Hi Dameon,

Thanks for the hint. Indeed something seems to go wrong with NAT. I will also check if the sk41916 might applied

Regards,

Benoit

Re: VPN & fwconn_key_init_links (OUTBOUND) failed

Also make sure it is not the backup firewall sending out packets through the primary.

This is something we see a lof if people start to monitor both firewalls with SNMP over the VPN connection.

Re: VPN & fwconn_key_init_links (OUTBOUND) failed

Hi,

We finaly solved our issue. It was a simple NAT rules that was conflicting with IKE trafic.... Rebuilding a narrowed NAT rule, and all the VPN came up !

Regards,

Benoit

0 Kudos