Create a Post
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted

R80.40 snmptrap v2 always cause engineID error

I have a .sh script on my test Security Gateway that sends snmptrap (I use SNMP version 2) to my monitoring service. This script was working fine on R80.30, but it does not work in R80.40 with Jumbo HF
Take_25.

Gaia OS configuration on both R80.30 and R80.40 is identical. SNMP v1\v2\v3 is enabled.

This is an example command that works successfully in R80.30 but gives an error in R80.40

snmptrap -c public -v 2c 1.1.1.1 "" 1.3.3.3.3.3.3.3 1.2.2.2.2.2.2 i 25

on R80.40 I got the error: "Can't set up engineID of type text from an empty string."

According to the sources of NET-SNMP engineID is used only in SNMP v3, but I explicitly use v2

I believe this is an error in snmp package.

 

Versions of snmptrap are different:

R80.40 NET-SNMP version: 5.8

R80.30 NET-SNMP version: 5.4.2.1

 

0 Kudos
6 Replies
Highlighted
Admin
Admin

We updated a lot of userspace tools/libraries in R80.40 with the move to the Linux 3.10 kernel.
That means some commands might operate slightly differently than before.
It's possible there's a different variant of that command that will work.

0 Kudos
Highlighted

I have to disagree. Sting "Can't set up engineID of type text from an empty string." only exist in snmpv3.c source file.

That means that key -v that is capable of SNMP version selection is ignored in snmptrap tool. And snmptrap tool always work in SNMP v3 mode whatever choice you make with -v key.

0 Kudos
Highlighted
Admin
Admin

The other option is this is a bug, in which case you should open a TAC case.
0 Kudos
Highlighted
Employee+
Employee+

Hi @Pavel_Grishin,

 

From where you are trying to run this command? looks like if you are running it from R80.40 machine is not working indeed but if you run it from other linux machine to your R80.40 GW it is working at least in my lab.

 

I will take it with RnD.

 

Thanks,

Ilya 

0 Kudos
Highlighted

I need this command to be run on R80.40 gateway, because my script monitors some parameters on this gateway and sends snmptrap to my monitoring server.

0 Kudos
Highlighted
Employee+
Employee+

@Pavel_Grishin ,

 

please open support ticket and share it with me, i will push it so you can get a fix.

 

Thanks,

Ilya 

0 Kudos