cancel
Showing results for 
Search instead for 
Did you mean: 
Post a Question

Change source IP on packet from Endpoint security client

Jump to solution

Hi, i have troubles with VPN connectivity (Mobile Access blade) on Checkpoint 4200 appliance. 

On Android/IOS everything works perfectly... there is problem only on Windows (haven't tryed on Linux). 

Problem is that packets from connected "Endpoint security" (or any other) client comes to internal network with source IP of appliance, not with ip of connected client. There is no NAT configured... also we tryed with different "Link selection" options but nothing helps.

Please help?

Thank you.

1 Solution

Accepted Solutions

Re: Change source IP on packet from Endpoint security client

Jump to solution

Hi Aleksander,

You are stating "There is no NAT configured." That sounds weird to me, you most probably have some sort of hide NAT configured for traffic going out to the internet?

Just make sure to add a no-NAT rule above all automatic rules that makes all traffic from the Office Mode range to your internal network  to use original source and destination.

Regards, Maarten
0 Kudos
2 Replies

Re: Change source IP on packet from Endpoint security client

Jump to solution

Hi Aleksander,

You are stating "There is no NAT configured." That sounds weird to me, you most probably have some sort of hide NAT configured for traffic going out to the internet?

Just make sure to add a no-NAT rule above all automatic rules that makes all traffic from the Office Mode range to your internal network  to use original source and destination.

Regards, Maarten
0 Kudos

Re: Change source IP on packet from Endpoint security client

Jump to solution

Hello,

fixed it. It was really strange, turned appliance upside down and nothing helped. 


In the end created new ip pool for office mode with nat turned off (it was off anyhow) and it works.

Very strange... anyhow thank you.

0 Kudos