Create a Post
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Silver

1400 Manual Cluster Failover

Hi all,

I'm struggling to remember or find the answer to how you manually fail over a 1400 cluster.  The normal "clusterXL_Admin down" doesn't work on 1400's.

I've set the other member to the higher priority in SmartDashboard and set ClusterXL to switch to higher priority member, then installed, but it hasn't switched.

Any ideas how I can manually fail over between cluster members on 1400's?

Thanks,

Matt

17 Replies
Highlighted
Employee+
Employee+

Are you able to physically unplug one of the Ethernet cables in the 1400 and force fail over?

0 Kudos
Highlighted

The SMB devices are a little bit different as they run Gaia embedded. Performing the following will perform the failover in the same manner as the Gaia full devices (3000 series and above).

# Complete in Expert mode

cd $FWDIR/bin

clusterXL_admin.csh down

Highlighted
Sapphire

Highlighted

The actual simplest way to do so, is by using the priority in the SmartConsole, as it is centrally managed, that is where it should be, open the cluster object, Cluster members and adjust the priority and push the policy.

For the quick switch the only way is to use the CLI as described in the previous posts.

Regards, Maarten
0 Kudos
Highlighted
Sapphire

If it is centrally managed - even 14x0 SMBs can be used locally managed.

0 Kudos
Highlighted

When using the priorities (with central management with SMS) if the failover settings within advanced settings are set to "Maintain Current Active Cluster Member" then the unit won't failover based on the priorities. Advanced Cluster XL Properties

If you want to perform failover using the priorities you will need to change to "Switch to higher priority cluster member" and then install policy. 

0 Kudos
Highlighted

Correct. You need to change option to "Switch to higher priority cluster member" in clusterXL setting. 

0 Kudos
Highlighted
Silver

Thanks everyone.

I've already set to highest priority and installed (as mentioned in the original post) but this did not switch members.  I don't know why not.

I'll try the clusterXL_admin.csh command tonight during a maintenance window Smiley Happy

Matt

0 Kudos
Highlighted

Not a problem at all. 

Just to confirm within your SMS have you set the "Switch to higher priority Cluster Member" option as pictured earlier?

If it's easier, feel free to post a screenshot and we can see if we can see anything that may be causing the issue.

0 Kudos
Highlighted

Hey Matt, how did you get on within your maintenance window and the failover with the command clusterXL_admin.csh?

0 Kudos
Highlighted
Silver

Here's my settings:

However, even after multiple installs, FWA is still Standby.  It should now be Active.

0 Kudos
Highlighted

Very Interesting, it looks ok to me from a clusterXL configuration point of view. What firmware version are you running? 

I have a pair of 1450 for lab use so I'll see if I can replicate the same results. 

Highlighted
Silver

Thanks.  I'm currently running on R77.20.70.

Highlighted
Platinum

There is no option in SmartView Monitor to perform failover ? Try to right click on active member within Monitor.

Kind regards,
Jozko Mrkvicka
0 Kudos
Highlighted

Please see below for SK for Best Practices on Manual Check Point failover. 

Best Practices - Manual fail-over in ClusterXL 

I would always recommend this method of a fail over. As from the CLI you can also obtain more detailed data quickly around clustered interfaces and cluster health etc. 

0 Kudos
Highlighted
Silver

The clusterXL_admin.csh down worked a treat Smiley Happy

One day the commands might be consistent between CP appliance models 

Highlighted

in expert mode, ip link set dev LANx down/up