Create a Post
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Participant

Endpoint client and Windows 10 1903

Jump to solution

Hi everyone,
has anyone tried to upgrade windows 10 to the 1903 version and install the endpoint client? in the release notes of ver 80.94 and 80.96 I see that it is not mentioned and does not seem to be supported yet. does anyone have feedback?

1 Solution

Accepted Solutions
Highlighted
Contributor

Hi Andrea,

 

On the "Endpoint Security Homepage" sk117536 under  "Client OS Support" you will see the following statement of Check Point:

2019-05-23 10_45_46-Endpoint Security Homepage.png

 

If you check sk115192 as they are referring to, you will see that the GA of Windows 10 1903 has been released on 21/05/2019. Thus it will be a matter of weeks before the EA client will be available and a couple of months before the GA client will be available.

 

So it is not recommended (due to not being officially supported) to install Check Point Endpoint Agent E80.96 (or E81.00 - which is new from 22/05/2019).

But you can try and see if it works, but be careful... 🙂

 

Kind regards,

 

Sean

 

View solution in original post

0 Kudos
20 Replies
Highlighted
Contributor

Hi Andrea,

 

On the "Endpoint Security Homepage" sk117536 under  "Client OS Support" you will see the following statement of Check Point:

2019-05-23 10_45_46-Endpoint Security Homepage.png

 

If you check sk115192 as they are referring to, you will see that the GA of Windows 10 1903 has been released on 21/05/2019. Thus it will be a matter of weeks before the EA client will be available and a couple of months before the GA client will be available.

 

So it is not recommended (due to not being officially supported) to install Check Point Endpoint Agent E80.96 (or E81.00 - which is new from 22/05/2019).

But you can try and see if it works, but be careful... 🙂

 

Kind regards,

 

Sean

 

View solution in original post

0 Kudos
Highlighted
Contributor

Might be a slightly different problem, but thought I'd share for anyone coming across this thread via Google..

Even with the latest clients I still ran in to installation problems on Windows 10 1903.  I'd get this error at the end:

 “An error occurred during the installation of assembly “Microsoft.VC80.ATL, type=”win32”, version “8.0.50727.42”

Been spending the last few days going back and forth with support with no resolution.  Tried Windows update and installing Visual C++ (https://support.microsoft.com/en-us/help/2977003/the-latest-supported-visual-c-downloads) but still no luck.


 

0 Kudos
Highlighted
Leader
Leader

I've got E81.00 just since yesterday on 1903 and it works like a charm 🙂

Jerry
Highlighted
Collaborator
E80.96 is working fine for me. You get a pop-up from Windows saying it may be incompatible but it works fine.
0 Kudos
Highlighted
Explorer

I tried upgrading W10 1809 to 1903 with E80.96, which did not work since windows does not want to upgrade (not compatible).

Uninstalling the 80.96 and installing the 1903 worked, but installing the latest E81.00 did not work, since the installer checks the windows versions and build, where 1903 is outside the windows of allowed versions...

Only solution was to go back to 1809 and install the R81.00

0 Kudos
Highlighted
Participant

I have tried various clients and getting the version conflict issue as mentioned in some of the other replies. Look's like we are going to be waiting for the release of the new version of the client which will hopefully be soon.

0 Kudos
Highlighted
Employee+
Employee+

A supported version of Endpoint Security client for Windows 10 1903 is yet to be released.

None of the current version (E81.00 is the latest) is supported on 1903 build.

0 Kudos
Highlighted
Advisor

Hope it soon will be released.

any EA version available at the usercenter?

Best Regards
Kim
0 Kudos
Highlighted
Advisor

Hi @Kiril_Kaper 

do you have any update in regards to Windows 10 1903?

I have tried to upgrade from Windows 10 1809 to 1903 and I have to first uninstall E81.00.7062 before I can install Windows 10 1903.

Was thinking of a possible need for a CFG version of E81.00?

Best Regards
Kim
0 Kudos
Champion
Champion

Currently, please do not upgrade to Windows 10 1903 when using EPS clients - even E81 client does not support Windows 10 1903. According to the SKs cited above, there will be a EA version soon, followed by a GA client ca. 6 weeks later !

Highlighted
Collaborator

Hello,

isn't Checkpoint getting the releases earlier than the customers? When can we expect a new release for 1903?

 

Best regards,

 

Jan

0 Kudos
Highlighted
Employee+
Employee+

 

  • E81.10 EA has been released and it supports Windows 10 19 H1 version 1903. Contact Check Point Support to get the EA package.
  • Two new features are now available in the Endpoint Security Client EA program:
    • BitLocker Management
    • Virtual desktop infrastructure (VDI) Persistent Support
    For more information please contact E81_EA@checkpoint.com

 

 

Highlighted
Collaborator

@Kiril_Kaper  Hi,

 

Sorry but I'm more confident with Network Security Check Point products than  EndPoint...

Usually for example in the JHFA package is explicitly stated which is the GA package and which is not (EA).

 

I know this could be a stupid question.. but how can I understand and be sure that an EndPoint client is in GA?

Typically when that specific version has its own release notes?

 

BR

RealD!Z 

0 Kudos
Highlighted
Employee
Employee

A very good question!  In order to see the GA releases the best way is through the Endpoint Homepage located here https://supportcenter.checkpoint.com/supportcenter/portal?eventSubmit_doGoviewsolutiondetails=&solut...

 

This will give you the latest releases that are GA.

 

Thanks!

 

Christopher Horridge

Highlighted
Employee+
Employee+
Please refer to sk102150 for GA build versions.
EA version will be a number less that GA, for example, E80.92:
GA build is 80.92.6149
EA build may be 80.92.6102

E81.10 GA build is 81.10.7191 - will be added soon to the SK.
Highlighted
Collaborator

Hi Guys @Kiril_Kaper @Chris_Horridge 

 

Thank you BOTH! 😄

 

0 Kudos
Highlighted
Participant

Version 81.30 works like a charm. 

Highlighted
Collaborator

Hi @AAAAAAAAAAAAALL!

 

I got a lot of trouble with FDE and upgrading in-place Windows 10 with several laptops models (HP, Dell, Surface..).

The problem seems to be with the firmware of machines.

 

Did you experience this issue before?

I just want to understand if other people encounter the same issue.

 

Thanks in advance,

Luca

 

 

0 Kudos
Highlighted
Explorer

I have the same Problem. @ Support any fix?

0 Kudos
Highlighted
Explorer

I have also the same problem to connect via checkpoint VPN Client.

Windows 10 x64 1903

VPN Client 80.96

and 82.00 ...  nothing is working.

The Client is reconncting 3 times and at least it is stopping the connection.

by the way, i installed a fresh Windows Version on the client...

How can i go on?

Thanks

0 Kudos