cancel
Showing results for 
Search instead for 
Did you mean: 
Post a Question
Highlighted

Automation Specialist : REST API Demo Tool not working

I am wondering whether you encountered the same issue: The REST API Demo Tool shows a lot of error messages while attempting to run it. Mostly, the error is similar to "Microsoft JScript Compilation error". So, could you please provide us with the latest version with no errors?

 

Thanks a lot for your cooperation.

CU Yasushi

7 Replies
Danny
Pearl

Re: Automation Specialist : REST API Demo Tool not working

Great to see you around Yasushi. Looking forward to your CCSM course in September.

Which Demo Tool are you referring to? I can't find it neither in Check Point's DemoPoint Environment nor in Jim's R80.20 API Automation & Orchestration training files.

Re: Automation Specialist : REST API Demo Tool not working

Hi Danny, 

nice to meet you! Well, I am in the city of Uppsala right now and I have tested the REST API Demo Tool which can be downloaded from the ATC site. Because, there are only few classes run in the past, nobody complained about the fact that the tool does not work at all. 

I have been teaching the CCSM R80.X class and that was really fun.

Kind regards,

Yasushi

 

 

 

Employee+
Employee+

Re: Automation Specialist : REST API Demo Tool not working

I'm almost 100% certain this is my old tool web tool. They got a really early version and never really reached back out to me regarding any issue. I'll speak with the team today.

 

It was incredibly light weight with just a few features not much can go wrong really. What seems to be the problem?

 

Re: Automation Specialist : REST API Demo Tool not working

Hi Joshua,

API_Demo_Tool_2.jpg

I copied the REST-API-DEMO_Tool from the ATC web site to my local hard disk drive. Launching this application leads to the following error message, and this is just the beginning of a series of dozens of subsequent error Messages. So, could you provide us with the lastest and stable version of this tool?

API_Demo_Tool_Error_Msg.png

Thanks a lot in advance!

 

!hadoT,

Yasushi

 

 

Employee+
Employee+

Re: Automation Specialist : REST API Demo Tool not working

Hmmm, did you deploy the VM Host? Should be an Ubuntu server. Is there a guide on how to set it up?

 

I've not seen how they packaged it and this doesn't look incredibly familiar.

 

Re: Automation Specialist : REST API Demo Tool not working

The last lab has the following title:


"Automating Tasks Using a Check Point API Enabled Web Portal". The Server used in this lab might be coded by you. This is a web-based Ubuntu system which can be used to launch a Web Portal to create or modify entries in the PostgreSQL database.

So, there is no one around who coded the other API Demo Tool?

 

0 Kudos
Employee+
Employee+

Re: Automation Specialist : REST API Demo Tool not working

I didn't say there is no one around. I originally though it was my tool and it still might be.

I've reached out to the team to see if we can get you some help.
0 Kudos