Create a Post
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted

Waagent high CPU Usage

Hi,

anyone also facing that Waagent using high CPU Usage even with a freshly deployed Gateway? For an existing one i did apply sk165055. On a fresh deployed Gateway i am faceing the issue again.

 

[Expert@fw2:0]# ps -o cmd fp 9732
CMD
python3 -u /usr/sbin/waagent -run-exthandlers
[Expert@fw2:0]# ps -o cmd fp 51494
CMD
fwd
[Expert@fw2:0]# waagent version
/sbin/waagent:27: DeprecationWarning: the imp module is deprecated in favour of importlib; see the module's documentation for alternative uses
import imp
WALinuxAgent-2.2.45 running on gaia 273.562
Python: 3.7.4
Goal state agent: 2.2.45
[Expert@fw2:0]# service waagent status
waagent (pid 9731) is running...
[Expert@fw2:0]#

0 Kudos
5 Replies
Highlighted
Admin
Admin

What version?
0 Kudos
Highlighted

If you are reffering to CP Version there is only R80.30 available in Azure (freshly deployed)

 

regards

Florian

0 Kudos
Highlighted

Hi,

R&D has updated the agent to Python3 and aligned the waagent with the most recent releases of waagent from Microsoft.

We have also released a specific SK for the issue you describe, please follow: https://supportcenter.checkpoint.com/supportcenter/portal?eventSubmit_doGoviewsolutiondetails=&solut...

 

Daniel

0 Kudos
Highlighted

Hi,

as i wrote i am totally aware of SK165055. And i did apply it on existing Gateway. However i have deployed a fresh machine with the updated Image (Feb 9 is mentioned in sk132192) which does already include the SK165055. My output shows the desired version 2.2.45. And this is the reason why i asked here if there are any known issues again. However i will file a ticked as soon as the issue appears again. (a reboot solved it for me)

regards

 

0 Kudos
Highlighted

We are not aware of such issues with the updated waagent, please open a support ticket once the problem reproduce on your environment with he updated waagent.

 

Daniel

0 Kudos