cancel
Showing results for 
Search instead for 
Did you mean: 
Create a Post
Nickel

Protocol violation detected with protocol:(IKE Nat traversal - UDP)

Hello

We are seeing this issue. and We have a problem with VPN communication.

Do you have any idea about that?

 

1. SG5100: R80.10 (Take 249)

2. Topology: 3rd party VPN <--- SG5100 (bridge mode) ---> 3rd party VPN

                     SG5100 is not set to VPN. It's just a bridge mode firewall.

3. Policy

11.PNG

4. Logs

Firewall - Protocol violation detected with protocol:(IKE Nat traversal - UDP), matched protocol sig_id:(10), violation sig_id:(20). (500)

22.PNG

0 Kudos
4 Replies
Highlighted
Gold

Re: Protocol violation detected with protocol:(IKE Nat traversal - UDP)

Kim,

first of all. Very interesting policy "any => any, allow" Hope this will be only for testing.

It looks like your VPN partners are not doing correctly the specifications for IKE_NAT-traversal.

You can try to create a new service-object with no protocol definition like this:

 

udp_4500.png

 and use this service object in your rulebase.

Wolfgang

0 Kudos
Highlighted
Nickel

Re: Protocol violation detected with protocol:(IKE Nat traversal - UDP)

Wolfgang,
Yes, it's only for testing. "any=>any,allow"

I created a new service-object with no protocol definition.
but the result was the same.

Firewall - Protocol violation detected with protocol:(IKE Nat traversal - UDP), matched protocol sig_id:(10), violation sig_id:(20). (500)

캡처.PNG

0 Kudos
Highlighted

Re: Protocol violation detected with protocol:(IKE Nat traversal - UDP)

Yeah, you get an alert - but what is your issue when i see action accept in log ?

0 Kudos
Highlighted
Nickel

Re: Protocol violation detected with protocol:(IKE Nat traversal - UDP)

G_W_Albrecht.

We have a problem with vpn communication between 3rd party devices.
The vpn service is no problem when removing checkpoint devices.
0 Kudos