cancel
Showing results for 
Search instead for 
Did you mean: 
Create a Post

show-simple-gateway error output

Hello,

the command: show-simple-gateway leads to following output:

{

  "code" : "generic_error",

  "message" : "Runtime error: Unmarshalling Error: Unable to create an instance of com.checkpoint.management.dlecommon.ngm_api.CpmiOwned "

}

Any ideas?

Tags (2)
13 Replies
Admin
Admin

Re: show-simple-gateway error output

Moving this to https://community.checkpoint.com/community/developers?sr=search&searchId=ad1e052a-d7fb-48e1-ab0b-fc0...‌.

Do you happen to have a copy of SmartDashboard and/or SmartConsole open?

0 Kudos

Re: show-simple-gateway error output

No, but if I run "show-simple-gateway" for another gateway is works and the same command with another gateway leads to the error.

0 Kudos
Admin
Admin

Re: show-simple-gateway error output

Ok, so it seems to relate to a specific object.

https://community.checkpoint.com/people/ubialbf7dd8c7-dd84-3fc4-99ca-eec4929a35ad‌ any ideas here?

0 Kudos

Re: show-simple-gateway error output

Did you find a solution for this problem?

0 Kudos

Re: show-simple-gateway error output

Appreciate if you can open a support request for this. Check Point Support is the place to investigate root causes and ensure that this problem does not happen to other customers as well.

0 Kudos
Employee++
Employee++

Re: show-simple-gateway error output

No need to open a support ticket.

This is a known issue and caused by - 

Corrupted Simple Gateway's multi_realms_for_blades configuration in Database - the multi_realms_for_blades container has an entry with empty realms.

The solution:

1. Close all SmartConsole windows and open GuiDBedit Tool.
2. On the Tables pane select the "Network Objects/network_objects" table.
3. On the right pane select the Simple Gateway object that causes the API failure.
4. On the bottom pane select the multi_realms_for_blades container field.
5. Check if there are entries with empty realms. If yes, right-click on the realm and select "Reset" action from the popup menu.
6. Finally, save the changes.

Robert.

0 Kudos

Re: show-simple-gateway error output

FYI guys - will be fixed in one of the next releases, however for now this is the workaround.

hope this helps

0 Kudos

Re: show-simple-gateway error output

It looks like I don't have a default value, the value is empty and stays empty after reset

0 Kudos
Employee++
Employee++

Re: show-simple-gateway error output

can you please add a screenshot of the whole container object (without any sensitive info)?

Robert.

0 Kudos
Highlighted

Re: show-simple-gateway error output

Thank you for all the help, Here is the screenshot

0 Kudos
Employee++
Employee++

Re: show-simple-gateway error output

Ok, your case seems to be different.

Please open a support request for this, so that Check Point support can investigate the root cause for your problem.

Robert.

0 Kudos

Re: show-simple-gateway error output

Did you find a solution for this? I am facing the same issue (and like you with only one gateway with the normal default multi_realms_for_blades).

0 Kudos

Re: show-simple-gateway error output

 I didn't get a solution for this, even with the help of the support team.

0 Kudos