Create a Post
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted

always returns empty search result while using filter option of "show-access-rulebase" API for domain with global policy(provider1)

Jump to solution

Hi,

I have a domain with global policy installed (provider 1).

To login I used following syntax:

{

"user" : "username",
"password" : "password",

"domain" : "domain name"

}

I am using "show-access-rulebase" API with filter option (packet mode), but it always returns null.

{
"offset" : 0,
"limit" : 20,
"name" : "uid of layer",
"details-level" : "standard",
"filter-settings" : {"search-mode":"packet"},
"filter": "23.23.23.23"

}

When I tried same from smart console I am getting the correct search result.

Tried the same API on a domain without global policy installed, search result returned is correct.

0 Kudos
1 Solution

Accepted Solutions
Highlighted
Employee++
Employee++

Re: always returns empty search result while using filter option of "show-access-rulebase" API for domain with global policy(provider1)

Jump to solution

Hi,

Unfortunately, this is a known bug in API code.

We have already fixed this and it should be released along with the next R80.10 Jumbo HF.

Please stay tuned.

Robert.

View solution in original post

6 Replies
Highlighted
Employee++
Employee++

Re: always returns empty search result while using filter option of "show-access-rulebase" API for domain with global policy(provider1)

Jump to solution

Hi,

Unfortunately, this is a known bug in API code.

We have already fixed this and it should be released along with the next R80.10 Jumbo HF.

Please stay tuned.

Robert.

View solution in original post

Highlighted

Re: always returns empty search result while using filter option of "show-access-rulebase" API for domain with global policy(provider1)

Jump to solution

Hi,

Thanks Robert.

It will be helpful if you can share take number for this jumbo HF.

0 Kudos
Highlighted
Employee+
Employee+

Re: always returns empty search result while using filter option of "show-access-rulebase" API for domain with global policy(provider1)

Jump to solution

The fix Robert specified is available in a private fix if required sooner, you can obtain it through support. The take number is unreleased yet and I'm not sure the info can be shared. Monitor the Jumbo page for updates.

0 Kudos
Highlighted

Re: always returns empty search result while using filter option of "show-access-rulebase" API for domain with global policy(provider1)

Jump to solution

Hi,

I have raised the ticket with support and they told me to install recent HF take_56.

But still getting the same result.

Can you share any reference to the HF which can be shared with support to resolve this issue?

0 Kudos
Highlighted
Employee++
Employee++

Re: always returns empty search result while using filter option of "show-access-rulebase" API for domain with global policy(provider1)

Jump to solution

Hi Ekta,

AFAIK the fix was NOT released yet. I'll inform our support team.

Sorry for inconvenience.

Robert.

0 Kudos
Highlighted

Re: always returns empty search result while using filter option of "show-access-rulebase" API for domain with global policy(provider1)

Jump to solution

Hi Robert,

Is there are any tentative timelines for the fix to release.

0 Kudos