Create a Post
cancel
Showing results for 
Search instead for 
Did you mean: 
Admin
Admin

SmartMove

Overview

Check Point SmartMove tool enables you to convert 3rd party database with firewall security policy and NAT to Check Point database.

The tool parses Cisco ASA (version 8.3 and above), JunOS (version 12.1 and above), ScreenOS (version 6.3 and above), Fortinet (FortiOS version 5 and above), and Palo Alto Networks (Version 7 and above) configuration file and converts its objects, NAT and firewall policy to a Check Point R80.x compliant policy. For PAN, we also convert application definitions (including Application Groups and Application Filters).

The tool is planned to support additional vendors and security configurations in the future.

The tool generates bash scripts by utilizing Check Point Management API's command line interface, to migrate the converted policy into a R80.x Management (or Multi-Domain) server.

Description

The tool is developed using Microsoft C# language and .Net framework version 4.5 (WPF application). The project solution file is configured for Microsoft Visual Studio 2012 and above.

Instructions

Code is available on GitHub: SmartMove

Tool can be downloaded from: sk111546 

Code Version

Code version 0.0.0

Tested on version

R80.10, API version 1.1

NOTICE: By using this sample code you agree to terms and conditions in this Terms and Conditions

...

30 Replies
Employee+
Employee+

All the information about SmartMove is available on sk115416

Watch Video

Link to Partners Map

Employee+
Employee+

There is a new version (1.4.6469.18822) available for SmartMove . It can be downloaded from sk115416

Employee++
Employee++

Hi All,

Just released a new version of the tool - added a support for Juniper JunosOS and ScreenOS configurations.

Please refer to sk115416.

Enjoy!

Participant

Hello,

I wonder how it can convert from junos 12.1 to R77.30 version?

Anyone try it have ?

0 Kudos
Reply
Admin
Admin

SmartMove cannot be used to move configurations to R77.30 versions of Check Point.

R80.10 is the minimum supported version per the SK.

Employee++
Employee++

Following up Dameon's answer, the source code of SmartMove is open to public on GitHub.

Anyone is free to download it and modify it to perform any task.

0 Kudos
Reply
Champion
Champion

Any plans for a Palo Alto converter? 

Regards, Maarten
0 Kudos
Reply
Employee++
Employee++

This vendor migration support is planned for this year.

Please stay tuned.

Robert.

Participant

Hi Yael. 

I cant access the SK. As I dont have advanced access. any idea how to get this access? I need to migrate 4 ASAs to CP firewalls 

0 Kudos
Reply
Employee++
Employee++

Hi Ammar,

I'll ask our SK publishers on next Sunday to make the acces regular.

Robert.

Participant

Thanks @Robert Deck, Much appreciated!!

0 Kudos
Reply
Employee++
Employee++

Done. Please try again, it should be accessible now.

Robert.

0 Kudos
Reply
Participant

I was able to download it. thanks a lot!

Champion
Champion

I cannot access sk115416 anymore. It says: To view this solution, higher access level is required.

0 Kudos
Reply
Employee++
Employee++

Hi Danny,

I've just asked our technical publications team to fix this.

Robert.

0 Kudos
Reply
Advisor

What about Fortinet convertor, any plans there as well?

0 Kudos
Reply
Employee++
Employee++

On the way, will be available soon.

PAN will follow.

Robert.

The solution is now external again so you should be able to access it.

0 Kudos
Reply
Advisor

Yes it is available now. The SK is written very well.

Collaborator

There are any EA version of Fortigate converter?

0 Kudos
Reply
Employee++
Employee++

There will be EA version very shortly.

Are you interested to participate?

Robert.

0 Kudos
Reply
Employee++
Employee++

The SmartMove tool now supports the Fortinet FortiOS migration.

Robert.

Admin
Admin

Updated the original post with that.

(I think we have a couple posts on this tool)

0 Kudos
Reply

Hi, is there a release date set for the palo alto support in this tool?

0 Kudos
Reply
Admin
Admin

Took a little longer than expected but a release that supports PAN is now available.

0 Kudos
Reply
Explorer

Hi - Is it possible to migrate from Cisco FTD ? Appreciate this is an old thread but am fast approaching a Checkpoint quantam install and need help with migration.

kigennetworks

0 Kudos
Reply
Admin
Admin

Believe only ASA is supported per the SK.

0 Kudos
Reply
Employee+
Employee+

Hi,

For Cisco the support only for ASA V8.3 and above  ,you can find it on sk115416

 

0 Kudos
Reply
Employee+
Employee+

We are currently working on smartMove for PAN

We plan to make it available during Q4 2018