cancel
Showing results for 
Search instead for 
Did you mean: 
Create a Post
Highlighted

R80.20 Mgmt API issue

Jump to solution

We need help with this issue happening in R80.20 , we see the API service stopping randomly and at that point we need to manually restart the service but of course we are trying to find out what is causing it to stop running randomly , this is very annoying.

 

Below is the output of the API status when the issue happens:

API Settings:
---------------------
Accessibility: Require all granted
Automatic Start: Enabled

Processes:

Name State PID More Information
-------------------------------------------------
API Stopped
CPM Started 4929 Check Point Security Management Server is running and ready
FWM Started 2192
APACHE Started 4180

Port Details:
-------------------
JETTY Internal Port: 50276
APACHE Gaia Port: 4434 (a non-default port)
When running mgmt_cli commands add '--port 4434'
When using web-services, add port 4434 to the URL


--------------------------------------------
Overall API Status: The API Server Is Not Running!
--------------------------------------------

Notes:
------------
To collect troubleshooting data, please run 'api status -s <comment>'

[Expert@cglscc4a:0]# api status

API Settings:
---------------------
Accessibility: Require all granted
Automatic Start: Enabled

Processes:

Name State PID More Information
-------------------------------------------------
API Stopped
CPM Started 4929 Check Point Security Management Server is running and ready
FWM Started 2192
APACHE Started 4180

Port Details:
-------------------
JETTY Internal Port: 50276
APACHE Gaia Port: 4434 (a non-default port)
When running mgmt_cli commands add '--port 4434'
When using web-services, add port 4434 to the URL


--------------------------------------------
Overall API Status: The API Server Is Not Running!
--------------------------------------------

Notes:
------------
To collect troubleshooting data, please run 'api status -s <comment>'

0 Kudos
1 Solution

Accepted Solutions

Re: R80.20 Mgmt API issue

Jump to solution

Is the API interface getting pounded by lots of simultaneous operations?  If so you may need to increase the amount of memory allocated to the API daemon, see here: sk119553: Security Management API server crashes under heavy load

Run api status -s blah then unzip the archive it produces.  Poke around in the various log files that were part of the archive, you will probably find some interesting log entries related to the crash.  Or just send the archive to TAC for inspection.

 

"IPS Immersion Training" Self-paced Video Class
Now Available at http://www.maxpowerfirewalls.com
10 Replies

Re: R80.20 Mgmt API issue

Jump to solution

Hi,

it is my first post here  🙂

 

so we had the same issue.

take a look at this sk119553

 

it helped for us starting on Version R80 till R80.20

Brgds

Dominik

0 Kudos

Re: R80.20 Mgmt API issue

Jump to solution
I m getting "command not found" when trying to run the commands suggested on sk119553 ... Am i doing something wrong??

[Expert@cglscc4a:0]# $ echo "_cpprof_add NGM_WEB_API_MAX_MEMORY 4096 0 0" >> /opt/CPshared/5.0/tmp/.CPprofile.sh
bash: $: command not found
0 Kudos

Re: R80.20 Mgmt API issue

Jump to solution

Do not include the $ symbol at the start.

"IPS Immersion Training" Self-paced Video Class
Now Available at http://www.maxpowerfirewalls.com
0 Kudos

Re: R80.20 Mgmt API issue

Jump to solution
Thanks Tim, that did it!
0 Kudos

Re: R80.20 Mgmt API issue

Jump to solution

Is the API interface getting pounded by lots of simultaneous operations?  If so you may need to increase the amount of memory allocated to the API daemon, see here: sk119553: Security Management API server crashes under heavy load

Run api status -s blah then unzip the archive it produces.  Poke around in the various log files that were part of the archive, you will probably find some interesting log entries related to the crash.  Or just send the archive to TAC for inspection.

 

"IPS Immersion Training" Self-paced Video Class
Now Available at http://www.maxpowerfirewalls.com

Re: R80.20 Mgmt API issue

Jump to solution

I agree with Tim.  Even though the SK stats that it was fixed int R80.20, I have had to increase the API memory on all our management environments (MDS and SDS).

0 Kudos
Admin
Admin

Re: R80.20 Mgmt API issue

Jump to solution
How much RAM and CPU do you have allocated for your management?
0 Kudos

Re: R80.20 Mgmt API issue

Jump to solution

I have 12 cores and 64gig ram - It is running on VMware.

0 Kudos
Raj_Khatri
Copper

Re: R80.20 Mgmt API issue

Jump to solution

We are experiencing the same issue as well after going to R80.20 where the API service keeps stopping.  We had the 2 commands added when we were running R80.10 which did the trick.  I just applied on R80.20 although it says it was fixed, so fingers crossed....  will continue to monitor.

 

#echo "_cpprof_add NGM_WEB_API_MAX_MEMORY 4096 0 0" >> /opt/CPshared/5.0/tmp/.CPprofile.sh
#echo "_cpprof_add NGM_WEB_API_JRE_64 1 0 0" >> /opt/CPshared/5.0/tmp/.CPprofile.sh
#api restart

0 Kudos
Raj_Khatri
Copper

Re: R80.20 Mgmt API issue

Jump to solution

Appears the issue is resolved and API service is remaining up.  Received confirmation from TAC that the fix is built into R80.20 but the commands still need to be added.  Previously, a hotfix for R80.10 was required in order for the commands to work.

0 Kudos