Create a Post
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Explorer

R80.20 - Crontab not triggering on MDS - $MDS_FWDIR/scripts/web_api_show_package.sh

Jump to solution

Hi Guys,

I am trying to run the script on MDS for specific CMA and when i copy paste it directly to expert mode it works well however when i am trying to put it in crontab its not triggering.

Also, is there any way we can change the file name of this (show-package-xx-x-xxx-xx)

Attached document for crontab output (where 192.168.1.50 is CMA IP)

Any suggestion guys.

 
 

 

 

 

 

 

 

0 Kudos
Reply
1 Solution

Accepted Solutions
Highlighted
Admin
Admin
You will probably need to create a script that sources a few items before calling the desired script.
See: https://community.checkpoint.com/t5/API-CLI-Discussion-and-Samples/Add-sources-inside-bash-scripts/m...

View solution in original post

0 Kudos
Reply
4 Replies
Highlighted
Admin
Admin
You will probably need to create a script that sources a few items before calling the desired script.
See: https://community.checkpoint.com/t5/API-CLI-Discussion-and-Samples/Add-sources-inside-bash-scripts/m...

View solution in original post

0 Kudos
Reply
Highlighted
Champion
Champion
On top of that you cannot use $MDS_FWDIR in the path to the script, you need to use a full path to your script.
Regards, Maarten
0 Kudos
Reply
Highlighted
Explorer

Yes i have used the path only, thanks for your input.

0 Kudos
Reply
Highlighted
Explorer

Yes, directly with crontab it didnt worked. however have created an another shell script and called this path inside that script it worked very well.
Thanks for your input.

0 Kudos
Reply