cancel
Showing results for 
Search instead for 
Did you mean: 
Create a Post
Aathi
Nickel

Installation targets showing "ALL Gateways in Smartdashboard"

Hi Team.

 

I have created a new policy and gateway via playbook .while executing the policy is installing on the correct target which i mentioned on the ansible playbook.while looking the manage policies on dashboard the installation targets is showing as all gateways even though i mentioned the particular targets on the playbook.

 

Please find the below playbook.

- name: "Push Access Policy"
check_point_mgmt:
command: install-policy
parameters:
policy-package: "{{hostname}}_Policy"
access: "true"
threat-prevention: "false"
targets: "{{hostname}}"
session-data: "{{login_response}}"

Here hostname is nothing but the firewall hostname. After pushing the policy while showing on the dashboard the target is showing ALL gateways not the hostname that is particular firewall.

Kindly help on this.

 

0 Kudos
6 Replies
Admin
Admin

Re: Installation targets showing "ALL Gateways in Smartdashboard"

The target refers to a specific gateway object, not necessarily a hostname.
Is there a gateway object that matches the hostname in this case?
0 Kudos
Aathi
Nickel

Re: Installation targets showing "ALL Gateways in Smartdashboard"

HI
yes in hostfile i have mentioned hostname as a firewall gateway
hostname: INDXXXXXXFW01
while executing via CLI its taking the correct target .but in dashboard
target is showing as ALL gateways for the policy which i created through ansible.
Regards
Aathi
0 Kudos
Bryce_Myers
Nickel

Re: Installation targets showing "ALL Gateways in Smartdashboard"

We've had this issue in R80.20 - and it appears to be related to the SOLR database interpretation.

To work-around this - we remove the installation targets and then set it to "All Gateways" and Publish.  Then we open it again and switch it back to what it should be and re-publish - and that cleans it up.

0 Kudos
Admin
Admin

Re: Installation targets showing "ALL Gateways in Smartdashboard"

The default policy installation targets for a given policy is All Gateways.
When you use install-policy to install policy and specify a gateway, it only applies to that installation.
It does not change the default shown in SmartConsole for that policy.
You can either set the installation targets when you create the policy package (either in SmartConsole or via API) or after the fact.
0 Kudos
Aathi
Nickel

Re: Installation targets showing "ALL Gateways in Smartdashboard"

HI,
Are u mentioning like the below playbook.
- name: "create-new-policy-package"
check_point_mgmt:
command: add-package
parameters:
name: "{{hostname}}_Policy"
comments: "Created by ansible during CheckMates demo"
color: "green"
threat-prevention: "true"
access: "true"
targets: "{{hostname}}"
session-data: "{{login_response}}"
is it the correct one.Please share the playbook if you have a working one
Regards
Aathi
0 Kudos
Admin
Admin

Re: Installation targets showing "ALL Gateways in Smartdashboard"

The correct parameter is installation-targets (not targets).
See: https://sc1.checkpoint.com/documents/latest/APIs/index.html#cli/add-package~v1.5%20
0 Kudos