cancel
Showing results for 
Search instead for 
Did you mean: 
Create a Post

Error in Publishing through API

Hi,

I'm facing an odd error when publishing for some rules. This might not be an API issue but R80.10 issue. This is the error I got from R80.10 after publishing - it happens only to some of the Policy Packages...

Error:

Publish failed because of validation errors

I'm aware of verification but what is the validation errors for publishing access rules?

Regards, 

Jun Liang

Tags (2)
0 Kudos
3 Replies

Re: Error in Publishing through API

I found the error already - I placed a network object as a service object into the access-rule accidentally due to my own database corruption. 

Hope this answer will help others in the future since this is only possible through API (GUI won't even allow you to choose the wrong objects) and am thankful for great validation checks by Checkpoint.

Re: Error in Publishing through API

Hi Jun,

thank you you for this feedback regarding the Check Point Validations. We are always happy to hear our customer’s thoughts.

do do you mind sharing how did you get to that corrupted state in the first place? Did you place that network object in the rule’s services using the Management API? Which syntax did you use?

0 Kudos
Highlighted

Re: Error in Publishing through API

Hi Tomer, 

Yes, I did place the network object into the rule's services using its UID. I stored the UID of the network object in my database as a service by mistake. 

I guess this kind of error can only occur using API and not GUI since GUI never use UID to operate.

0 Kudos