cancel
Showing results for 
Search instead for 
Did you mean: 
Create a Post

Creating Rules in R80.10 domain controlled by multi domain server (Provider 1) using R80.10 API

Jump to solution

Hi,

I have a multi-domain server (Provider 1) with a domain (without any global policy assigned).

Tried creating a rule using R80.10 API but it shows "Requested object [Network] not found" error.

I am able to log in, create a host but not able to do anything which requires layer information using R80.10 API.

Tried creating a new layer as well but it shows "Runtime error: An internal error has occurred."

How are we supposed to create a rule for such type of setup?

1 Solution

Accepted Solutions

Re: Creating Rules in R80.10 domain controlled by multi domain server (Provider 1) using R80.10 API

Jump to solution

Hi Tomer,

I was using below syntax to login to a domain before:

{

"user" : "username",
"password" : "password"

}

But login to the domain with below syntax solve the problem of "Object not found" and "empty layer list":

{

"user" : "username",
"password" : "password",

"domain" : "domain name"

}

Now I am able to create a rule as well as able to fetch the list of all the layers.

6 Replies
Admin
Admin

Re: Creating Rules in R80.10 domain controlled by multi domain server (Provider 1) using R80.10 API

Jump to solution

Moving this to Developers (Code Hub)‌.

Generally, you should be able to create rules and the like using the API with Multi-Domain.

All the API calls should have a "Domain" parameter to make sure you are executing the command in the correct domain. 

It would help if you could post the exact API calls you were making.

Re: Creating Rules in R80.10 domain controlled by multi domain server (Provider 1) using R80.10 API

Jump to solution

Hi,

I was using "add-access-rule" API to create rule and "add-access-layer" to create the new layer.

These Apis don't have "domain" parameter.

This problem is solved by making login call using "domain" parameter.

0 Kudos
Admin
Admin

Re: Creating Rules in R80.10 domain controlled by multi domain server (Provider 1) using R80.10 API

Jump to solution

RIght, you have to log into the correct domain when you create the session.

I was misremembering the AP documentation.

0 Kudos

Re: Creating Rules in R80.10 domain controlled by multi domain server (Provider 1) using R80.10 API

Jump to solution

can you please specify the API syntax which you have been using to login, create the network, and then create the rule with the "object not found" problem?

0 Kudos

Re: Creating Rules in R80.10 domain controlled by multi domain server (Provider 1) using R80.10 API

Jump to solution

Hi Tomer,

I was using below syntax to login to a domain before:

{

"user" : "username",
"password" : "password"

}

But login to the domain with below syntax solve the problem of "Object not found" and "empty layer list":

{

"user" : "username",
"password" : "password",

"domain" : "domain name"

}

Now I am able to create a rule as well as able to fetch the list of all the layers.

Highlighted

Re: Creating Rules in R80.10 domain controlled by multi domain server (Provider 1) using R80.10 API

Jump to solution

Thanks Ekta. I was stuck at the same point.

0 Kudos