cancel
Showing results for 
Search instead for 
Did you mean: 
Create a Post

Argument 'name' in show-object not implemented?


If I try to show an object and use the name argument, I've got an error that parameter name is invalid.

# mgmt_cli show object name "nntp.ilk.net"

code: "generic_err_invalid_parameter_name"

message: "Unrecognized parameter [name]"

Also in API Web Services. The reference documents name as vaild argument.

Is this an known bug?

Thanks,

Alex

Labels (2)
0 Kudos
5 Replies
Highlighted

Re: Argument 'name' in show-object not implemented?

Agreed that this "name" parameter does not work, the uid parameter works fine.

the web_api also returns

{

  "code" : "generic_err_invalid_parameter_name",

  "message" : "Unrecognized parameter [name]"

}

0 Kudos
Employee+
Employee+

Re: Argument 'name' in show-object not implemented?

This does indeed look like a bug.

While we look into this you can try using the specific object type which are working as expected - show host, show network etc.

Hope that helps.

Yonatan

0 Kudos

Re: Argument 'name' in show-object not implemented?

Thanks, workaround helps. Looking forward to an bug fix.

Regards,

Alex

0 Kudos

Re: Argument 'name' in show-object not implemented?

Hi,

it still doesnt work according to sk113078. With name or with host. Any solution?

[Expert@chkp-sms-r80.10:0]# cat host.csv
name,ip-address,color
host-api1,2.1.1.1,green
[Expert@chkp-sms-r80.10:0]# mgmt_cli add host --batch host.csv
Username: mras
Password:
Line 2: code: "generic_err_invalid_parameter_name"
message: "Unrecognized parameter [name]"


[Expert@chkp-sms-r80.10:0]# cat host.csv
host,ip-address,color
host-api1,2.1.1.1,green
[Expert@chkp-sms-r80.10:0]# mgmt_cli add host --batch host.csv
Username: mras
Password:
Line 2: code: "generic_err_invalid_parameter_name"
message: "Unrecognized parameter [host]"

BR

Martin

0 Kudos

Re: Argument 'name' in show-object not implemented?

fixed, "host" is a reserverd word, I removed it from the name and its working now.