Uri Bialik

Getting a "Forbidden" error message (HTTP status code 403)

Discussion created by Uri Bialik Expert on Jan 12, 2016
Latest reply on Aug 18, 2017 by Dameon Welch Abernathy

In some scenarios browsing to https://<management-server>/web_api/ may lead to seeing this error message:

 

Forbidden

You don't have permission to access /web_api/login on this server.

 

What does it mean?

 

It means that the API server is not configured to accept requests from the machine running your browser.

For security reasons, the default settings for the API server allows him to accept requests only from the management server itself and not from any other IP address.

 

If you want your management server to accept API requests from other machines, please follow this procedure:

* Open SmartConsole and log into your management server. If you have a multi-domain environment, log into the MDS domain.

* Click on the "Manage & Settings" button on the left.

* Select "Blades"

* Look for the "Management API" section and click on "Advanced Settings".

 

Now you can choose between three options:

1) Accept API calls from the management server only (the default setting)

2) All IP addresses that can be used for GUI clients.

    This option would allow the API server to accept requests only from IP addresses that can be used to connect with the management server using SmartConsole.

3) All IP addresses

 

Once you make you selection:

* Click the publish button

* Use SSH to log into the management server in "expert mode" and type "api restart".

Outcomes