George Liu

Failed to Load Security Policy: Cannot allocate memory

Blog Post created by George Liu on Apr 19, 2018

Affected version: R71 SPLAT

 

Sympton:

1. install policy, Failed to Load Security Policy: Cannot allocate memory.

2. Gateway disk space not full.

 

Check procedure:

1. manual fetch policy from gateway, got same error message

   (fw fetch SmartCenterIP)

 

2. check cpd.elg, memory allocate fail.

    ($CPDIR/log/cpd.elg)

 

3. check kernel tab, found string_dictionary_table full

   (output from fw tab -s)

 

Workaround:

1. Disable log rulebase uuid.

    (Policy -> Global Properties -> SmartDashboard Customization -> Configure -> Firewall -> General
Uncheck rulebase_uids_in_log ; click ok; then push policy.)

Outcomes