Jumbo Jail - Stuck between installing newer jumbo and uninstalling older one

Document created by Eric Oakeson Employee on Jan 28, 2019Last modified by Eric Oakeson Employee on Jan 29, 2019
Version 4Show Document
  • View in full screen mode

Have you ever had a time when CPUSE is telling you that BOTH:

1) It cannot install a newer package because it cannot install the old one,

2) It cannot reinstall that older one because it thinks it's already there?

 

There is hope! This actually happened to me while restoring a VMware snapshot of my own management server virtual machine. It was a fun day in the lab, as both my previous Gaia backups had gotten corrupted. Take multiple backups/snapshots! Once the VM was restored, I got stuck trying to put the latest jumbo for R80.10.

 

The snapshot had Take_40 jumbo installed (yes, it was old). I tried to then updated it via CPUSE, but when it tried to uninstall Take_40, it said it couldn't find the package. Yet, CPUSE was saying it was installed. I tried to reload the Take_40 jumbo manually, but then it said it already existed. I couldn't update, and I couldn't uninstall the old one. With some crafty work around recreating the "pointers" to the jumbo, we can get out of this situation.

 

You're basically going to follow sk115243, but I describe on how to find and recreate the missing pointers yourself, as it was in my situation a very old jumbo installed on there and wasn't available anymore. Looking at the logs, I discovered it was telling me what was missing, and I just had to recreate it.

6 people found this helpful

Attachments

Outcomes